0

Somehow I wasn't logged in to my account, so I have to repost my question. Sorry about that.

What I currently have:

  • When I open ConEmu.exe, it opens Git Bash
  • When I run cmd.exe, it runs ConEmu but uses the Windows command-set (can't use 'ls' for example)

What I want:

  • When I open cmd.exe, I want ConEmu to use Git Bash instead of the Windows command prompt.

I hope this makes more sense. Pictures of my settings:
Integration Settings Startup Settings

0

You make me crazy.

When I run cmd.exe I want to run bash.exe.

Really?

  • I don't think we are on the same page. If I wanted to run bash.exe, I would. But that would just give me the Git Bash with it's own interface without ConEmu. The quickest way I know how to open a command prompt, is Windows Key + X and press 'C' which opens the Command Prompt. That's why I want the cmd.exe to run ConEmu (which it does!, but without the Git Bash integration). – Cake Mar 25 '16 at 14:49
  • Git Bash - is the bash.exe. cmd.exe is completely different command line interpreter, undoubtedly. – Maximus Mar 25 '16 at 18:23
  • Your question looks like "When I start Photoshop, I want MS Word to be started instead". I doubt that you really want that. – Maximus Mar 25 '16 at 18:30
0

This actually an entirely normal thing to do, seeing as:

  1. Git-Bash default "theming" is an unnecessarily generous use of the word
  2. Getting the convenience of ConEmu
  3. Avoiding the process of opening one shell to open another shell, because opening one thing to open a different instance of said thing is only appropriate for Russian nesting dolls.

I just did this and it was frustrating but here you go:

  1. Open conemu settings (win+alt+p)
  2. Add task- plus sign at the the bottom
  3. Use any task name you'd like
  4. In parameters: /single /dir "{Path to Desired Starting Dir}"
    • optionally: \icon "{Path to Git Installation}\Git\mingw64\share\git\git-for-windows.ico"
  5. In the commands box: {Path to Git Installation}\Git\bin\sh.exe --login -i

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.