0

I have a situation as described below :

Router 1 (Dlink DSL-6850u) is used as a VDSL model, and provides wifi to half of the house. It controls subnet 10.0.0.138

Router 2 (TP-Link TD-W9980) is connected via a long LAN cable to the first router. Router 2 was set as 192.168.1.1 and is connected to router 1 via static ip 10.0.0.10

It gives services to the rest of the house through its own DHCP service.

Now all worked perfectly, I had manually configured ports for remote control of my desktop which is connected to router 2 via lan cable, torrents etc all worked.

Until I added a NAS server connected to router 2 via lan cable.

Now when I tried to access the NAS from the first half of the house (router 1) - no route to host! Although clients on router 2 can access the router 1 network!

I tried to do something with IGMP settings, enabling LAN to LAN multicast, etc. Didn't work - clients on Router 1 can't access router 2's subnet.

I also tried the popular advice of disabling DHCP on router 2, but the clients dont get any DHCP response from router 1.

I am running out of ideas, I know that it is possible! Question is how exactly...

Please advise, networking experts.

  • 2
    You currently have 2 networks. You want one network, to get that turn off dhcp on the second router and assign a static ip to it within the first networks IP range. If both devices have IPs in the same network you will only need one dhcp server, it will answer even if the device is connected to the other routers hardware. What devices are part of a network has more to do with what IPs are used than physical connections. – Tyson Mar 25 '16 at 15:15
  • 1
    Also don't plug the second router in via the WAN port, use one of the LAN ports for the connection to the first router. – Tyson Mar 25 '16 at 15:59
  • I get error code 5003: Then LAN IP should not be in the same subnet with WAN IP. Please input another one. – Carmageddon Mar 25 '16 at 16:08
  • 1
    You'll probably have to get the second router setup disconnected from the first. When you plug it in use a LAN port instead of the WAN port to connect it to the first...I.e. The interconnecting cable should plug into a LAN port on both routers. – Tyson Mar 25 '16 at 16:17
  • A diagram may help us understand what's going on. Are you running two DHCP servers? You really only need one; by disabling DHCP and routing features on one, you'll effectively turn it into a switch. Connect that via a LAN port, and you'll have only one device serving IPs etc, which will greatly simplify your setup. – Hefewe1zen Mar 26 '16 at 1:51
1

See if it can be set up as a bridge instead of a router.

Apparently by setting "WAN Connection Type" to "Bridge" on the WAN Configuration page WAN Service panel according to the online manual for the TD-W9980

I have seen APs detect if their WAN is plugged into another AP, and ask if they should go into extender mode. Probably confusing of me to call that a range extender

  • I don't want it as a range extender. I want to use LAN whenever I can - the connection quality is uncomparable. – Carmageddon Mar 25 '16 at 16:14
  • I fixed it. I didn't mean to imply linking them by RF – infixed Mar 25 '16 at 16:46
  • Under Network > WAN Settings > connection type There is only dynamic IP, Static and PPPoE. – Carmageddon Mar 25 '16 at 19:01
  • If I don't use the 4th port which is wan/lan combo, I don't have enough ports on the second router.... – Carmageddon Mar 25 '16 at 19:01
  • I was reading here: tp-link.us/faq-445.html The Advance Settings button may be pertainent. – infixed Mar 25 '16 at 19:23
1

I bet you plugged the ethernet cable from the 1st router in the WAN port of the second router. This isolates everything and creates a second network that can't be reached from outside. Setting IP addresses the same won't be enough.

But the solution is really simple. Unplug the cable from the WAN port, and plug it into one of the LAN ports. This effectively disables the router function from WAN to LAN translation while the Wifi still works. Make sure you disable the DHCP on the second router if its enabled, or people from the entire network will be fighting for leases from either DHCP server which will yield in weird results.

In the router, it probably still wants you to do something with WAN, just give it a fake ip address. Doesn't matter. Make sure the router itself has an IP address that is inside the networkrange of the first router, so you can still access the router's admin page. Of course, the IP address should also be outside of the scope of the first.

For example: 192.168.0.1 for router 1, 192.168.0.2 for router 2, DHCP range starting from .50 to 150.

  • My problem is that the second router only has 4 ports, the one that I connected to the first router is combined wan/LAN port, bit I can't figure out how to specify that it is LAN and not WAN. – Carmageddon Mar 25 '16 at 18:52
  • See if it has a physical button somewhere. – LPChip Mar 25 '16 at 18:52
  • There should be an operator mode in the administration panel. You have to set this one to vDSL Modem Router mode. – LPChip Mar 25 '16 at 18:56
  • "it probably still wants you to do something with WAN, just give it a fake ip address" – I was so stuck about not finding an option to just disable WAN... I'm still amazed that this is the solution. Thanks! – Dániel Kis-Nagy Sep 18 '19 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.