0

When I try to ssh from the host to the guest, the connection is refused.
How do I set this up?

  • I have a Win7 host and an Ubuntu server 14.04 guest.
  • I have 2 interfaces set up, eth0 in NAT and eth1 in host-only with a static IP (192.168.56.56).
  • I can ping the guest from the host on that IP.
  • I can ssh from the guest to itself with ssh user@192.168.56.56

However when I try to execute ssh user@192.168.56.56 from the host, I get connection refused.


Notes and updates:

  • It's not a firewall issue. I disabled the firewall on the guest and I still can't connect.
  • Might be a firewall issue. – jlliagre Mar 25 '16 at 16:27
  • @jlliagre how do I find out? – ewok Mar 25 '16 at 16:28
  • The simplest way is to temporarily turn off your firewall – jlliagre Mar 25 '16 at 16:29
  • @jlliagre go on... – ewok Mar 25 '16 at 16:29
  • Hmm, you don't know if you have a firewall in the first place? – jlliagre Mar 25 '16 at 16:36
0

Sorry, I cannnot comment here as yet.

Down you interfaces in Ubuntu, then Up only Eth1 and try to connect again from host.

Also, show content of your /etc/network/interfaces.

If you try to connect as a root check if root login is permitted in sshd settings.

What can you see using telnet from host? I mean

telnet 192.168.56.56 22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.