1

I upgraded my work laptop lenovo T540P from Windows 8.1 to Windows 10. There were some issues like DisplayLink not working or a BSOD in Synatpics Touchpad driver which were all resolved by using the lenovo System Update to update the drivers.

But I have completely lost Bluetooth and the System Update hasn't helped with that. Some observations:

  • There is no Bluetooth section in Settings/Devices

  • Device Manager shows an "Unknown Device" under Other Devices, which has the error "The drivers for this device are not installed. (Code 28)". There is no Bluetooth device anywhere in device manager

  • Every run of Lenovo System Update prompts for installing "Intel Bluetooth Device Software - Initial Install - 10[64]", even after installing it

  • Installing Bluetooth drivers downloaded from Lenovo, outside the System Update tool didn't help either

  • Lenovo Enterprise Support recommends reverting to Windows 8.1

If I buy an external Bluetooth dongle, will it be recognized or can I expect to have similar issues with it as well?

  • Have you tried downloading/installing the Bluetooth driver manually, outside of the ThinkVantage System Update tool? There are certainly Windows 10 versions of the driver. support.lenovo.com/us/en/products/laptops-and-netbooks/… – root Mar 25 '16 at 20:30
  • Yes I did, actually even before I tried the update tool. Same result. – Miserable Variable Mar 25 '16 at 20:36
  • You should edit your original post to include that, it will help others. Do you have any Windows updates? Does the Bluetooth device appear in BIOS? – root Mar 25 '16 at 20:41
  • Thanks @root. I have updated my post, I will check the BIOS now. – Miserable Variable Mar 25 '16 at 20:43
  • There is no Bluetooth anywhere in BIOS/Config tab. But my Bluetooth was working before 8.1 to 10 Upgrade. – Miserable Variable Mar 25 '16 at 20:51
0

I have upgraded to W10 in Nov 2015, and intel bluetooth worked fine then. Today I experience the same problem as you do. I have a pending intel bt update in the windows update queue that fails to install consistently. I suspect it is the culprit.
I'll try a clean re-install of W10 (boot from DVD, reformat) soon and will let everyone know here. I dual boot linux on this machine. BT works fine there - i.e. it's not a hardware issue.

I reinstalled my W10 last night. BT works fine by installing a recent intel bluetooth driver from windows update. I suspect the culprit is the intel prowireless bluetooth driver 17.0.1405.0464 that I inherited from W81. I could not remove this software. Once again, MS operating system needs a clean install to work correctly.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.