1

I finished some work and I wanted to commit it but SVN commit failed. I tried some advices without any luck. I am using Android Studio.

What I have done before the error occured:

  • upgraded debian to the latest version
  • fixed SSL error (see my previous question)
  • installed LetsEncrypt certificate
  • added new directory with file to local SVN repository
  • modified many files in local rep
  • reverted add of new directory
  • removed one Test file from local repository

Then I tried to commit all changes and it failed that deleted test is out of date. I ran svn upand repeated commit but it failed with infamous Base checksum mismatcherror. I found some advices so I moved local repository away and provided fresh checkout. I copied modified files back (without SVN repo files) and tried commit again - same behaviour.

Then I went to server and ran svnadmin verify on my repository. I checked out the repository again, I deleted just the test file and attempted to commit it - fails with svn: E155011: File is out of date. It makes no sense. What else can I try?

[Mon Mar 28 09:56:12.444710 2016] [dav:error] [pid 15202] [client 82.99.:53925] Unable to PUT new contents for /svn/xx/!svn/wrk/63c738bc-5301-0010-80f14d746ece7f88/repo/app/src/androidTest/java//FormulaTest.java.  [403, #0]
[Mon Mar 28 09:56:12.444759 2016] [dav:error] [pid 15202] [client 82.99.:53925] Could not prepare to write the file  [500, #200014]
[Mon Mar 28 09:56:12.444767 2016] [dav:error] [pid 15202] [client 82.99.:53925] Base checksum mismatch on '/repo/app/src/androidTest//FormulaTest.java':\n   
expected:  7290b9a9dd43b2c9236fa6f55417a398\n     
actual:  4874627488b5b5a8b58e374685c9b889\n  [500, #200014]
1

Ok, I attempted to checkout 1.6 SVN format and then commit worked. Inspiration: https://stackoverflow.com/a/29400059/1639556

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.