1

The situation for my Backup System

  • NAS DLINK DNS323
  • Software for backup: "Cobian Backup 11 Garvity"
  • Cobian is setting for backup in lan via FTP and delete the old backup

The problem is this. When Cobian attempting to delete the old backup it return this error:

Can't remove directory: Directory not empty

If I try to delete the same folder with FileZilla, it return the same error:

RMD E-Commerce 2016-03-12 18;00;54 (Completo)

550 Can't remove directory: Directory not empty

Checking the folders (via the browser windows because the folders are shared), I can see that remain inside all the files starting with dot (ex.: ".gitattributes"). With FileZilla I can't see this files, and I think this is the same for Cobian and it can't delete it.

How can I resolve this problem ? I don't want to delete manualy, I want resolve the problem for the future, my backup must go automaticaly deleting all the old folders !!

Thanks

  • Did the answer posted below help you? – root Mar 30 '16 at 12:06
  • @root Sorry, I have not forgotten !! Your answer is certainly correct, but incomplete for the solution. Before giving it as the correct answer, I want to be able to solve and complete the question with the integration of the solution. Unfortunately I can not configure "pure ftpd" to display the "dot [files]". I was able to connect with telnet to the NAS and I added in "etc/pure-ftpd/conf/" the file "DisplayDotFiles" with "yes" in it (and I have followed many guides, and already lost several hours) but nothing !! – Baro Mar 30 '16 at 13:03
  • Why did you even have an /etc/pure-ftpd/ folder? Is the DNS-323's FTP server based on a ProFTPD foundation? Unfortunately, the user manual for your NAS does not mention a feature to return hidden files when sent a list command. You may want to consider writing a script to purge dot files in advance, handling this task outside of FTP. See pages 30-31 for FTP information on your NAS: files.dlink.com.au/Products/DNS-323-500GB/Manuals/… – root Mar 30 '16 at 16:06
  • Under "etc" I have only the file "pure-ftpd.conf", I created the folder and the file "etc/pure-ftpd/conf/DisplayDotFiles" according to the guide. One solution could be compress all before upload backup (I would prefer not to change the file names). But are about 7gb for backup, recovery would be impractical, and also I like to win on my computer !! :D Tonight I'll try again !! – Baro Mar 30 '16 at 16:36
1

Files that start with . are hidden files.

From Cobian's FAQ, When deleting a FTP directory, hidden files are not deleted:

The problem is: to be able to delete a directory, the program must recursively delete all files and subdirectories present on the remote site. In order to do this, the program requests a list of files. Some servers can be configured to send the hidden files as well, but some others don't do that. In that case, the program will delete all other files, but not the hidden ones, and of course, the parent directory will not be deleted. Check if with your FTP server allows to send hidden files when a list command is received. For example, Proftpd can be configured to send hidden files in a listing: File : /etc/proftpd/proftpd.conf Modification : ListOptions "-1" replace by ListOptions "-A" #List all files except "." and ".."

In version 10, you can add a parameter to force the server to send you the listing with all hidden files. Again, the server must support this.

  • I mark the answer as correct (is the right way!), but I promise that as soon as I can dedicate the necessary time if I'll find the solution I will update my question with the complete solution. Thank you !! – Baro Apr 2 '16 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.