6

I actually use the new task view tool provided in Windows 10 and I was wondering if there is a way to disable the sliding animation between different desktops. I find this kind of annoying and it seems to take a second each time for the animation to play. It would be great if there was a way to disable this so each time I switch to a desktop, it switches instantly instead of playing the animation.

12

Control panel → System → Advansed system settings → Performance settings. Uncheck "Animate windows when minimizing and maximizing".

  • Thanks, I thought I would have to dig a lot deeper to change this, do you know by chance if there's a way to just change the sliding animation but not minimizing/maximizing windows? – Tom Mar 28 '16 at 20:20
  • 1
    ooh it's so much faster without animation. thank you! – Morgan T. Jan 3 '17 at 14:08
  • Not sure why, but for me Win10 machine I had also to uncheck the first option to disable Task View sliding animation, an option called "Animate controls and elements inside windows" – Vinicius Xavier May 10 '17 at 18:55
  • holy crap windows just got fast! although to be fair minimizing animations never hurt anyone ) it's this damn super-slow sliding thing that is so annoying – Mikey Sep 11 '17 at 15:39
  • 4
    In Win 10 version 1803, Animate windows when minimizing and maximizing controls desktop sliding, while Animate controls and elements inside windows appears to control sliding of the task bar buttons. – Andriy M May 17 '18 at 14:18
0

Only with OFFICE 2016 products, windows weirdly slid around when they were selected and moved - far delayed behind the mouse movement. I had to use WINDOWS-U first, to turn off 'Show Animations in Windows' - this deselected several things in the Performance settings dialog mentioned above. This helped 90%, but the window movement was still slightly delayed behind mouse movement when dragging. The final change that worked was the Show Window Contents While Dragging getting turned off. Performance is now snappy like it ought to be (as it IS for ALL other apps on the machine!). Turned off: Animate controls and elements inside Windows, Animate windows when minimizing and maximizing, Fade or slide menus into view, Fade or slide ToolTips into view, Fade out menu items after clicking, Show window contents while dragging, Slide open combo boxes, and Smooth-scroll list boxes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.