3

A couple of months ago I started using comments in some documents, and it was useful to create PDFs of these pages with these comments in the margins.

However, for some reason now LibreOffice takes 'print comments in margin' as the default setting, even if the document has no comments.

This means that when I go to print a document (to a PDF writer, but the actual printer is irrelevant) with no comments, the document is squeezed into about 75% of the page, to make space for non-existent comments!

The option to print with no comments is greyed out, so for every page without comments that I want to turn into a PDF, I have to add an empty comment, and then select 'no comments' in the print dialog.

This is really frustrating for me. When I open a new Writer document, the setting under Tools > Options > LibreOffice Writer > Print > Comments goes to In margins by default.

I have no idea why Writer has decided this should now be my default, and I would really love to know how to change this back to None.

Thanks in advance for help with this.

  • Welcome on SuperUser. Please edit your post adding the version of libreoffice you are using. It could help people to search a solution for your problem. Did you ever change the default template? Comments were buggy a long time ago, but it seems it was fixed... – Hastur Mar 29 '16 at 8:13
  • I'm using version 4.4.1.2. Thank you for the link - I never actively changed the template, but I have now created a new template with 'no comments' as the default setting, and set this as the default template. Seems to have solved the problem! Thanks again. – Alistair P Mar 30 '16 at 12:44
2

Probably your default template was somehow changed.
You can fix creating a new template for the default page without the undesired features.

This is a way to do it:

  • Open a new empty document
  • Tools > Options > LibreOffice Writer > Print > Comments > None

Then follow the step-by-step procedure to change the default template from the wiki page of Libreoffice [1]:

  • Choose File - Templates - Save As Template.
  • In the New Template box, type a name for the new template.
  • In the dialog that appears, double-click the "My Templates" folder, and then click Save. You will then be prompted for a name; write it and click OK.
  • Choose File - New - Templates.
  • Double-click the "My Templates" folder.
  • Click on the template that you created, and click Set as Default.
  • Close the dialog.

Alternatively you can purge and install again Libreoffice, or hope that with the next major update the default template is overwritten, but I think to this is [2] "to break a (butter)fly on the wheel".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.