1

This question already has an answer here:

I'm trying to open the calculator app on my Windows 10 64 bit machine.

When I search for calc in the start menu and click it, I get an error

you'll need a new app to open this

I tried re-registering my windows ten apps by using this command

Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

with a powershell running as administrator and the same issue still occurs.

How can I fix my calculator?

marked as duplicate by Ramhound, Ben N, mdpc, Hennes, Andrew Lambert Apr 3 '16 at 4:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5

Press WinKey + R, and type this and press {ENTER}:

%systemroot%\system32\calc.exe

If Calculator doesn't open, try these two PowerShell commands.

Get-AppxPackage Microsoft.WindowsCalculator -allusers | select PackageFullName

Note down the Package ID from the last command. For instance, if the Package ID is displayed as "Microsoft.WindowsCalculator_10.1601.49020.0_x64__8wekyb3d8bbwe", mention it in the next command:

Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1601.49020.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -DisableDevelopmentMode

Make a note of the error messages, if any.

  • I had the App Icon missing from my tray and this fixed it. Thanks! – Codingale Nov 22 '17 at 2:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.