1

a family computer upgraded to Windows 10 and we've lost internet connectivity in a browser.

ping works and also resolves DNS entries

But when connecting through Edge or Firefox, it gets stuck on loading. In the developer toolbar the request never gets a response and keeps hanging.

I've tried:

  • disabling and re-enabling network interface
  • ipv4 and ipv6 are enabled in the network interface settings (also tried enabling only ipv4)
  • ipconfig /flushdns
  • netsh winsock reset
  • proxy is disabled for local connection (also tried in Firefox explicitly say "no proxy")
  • restarting

Any ideas how to diagnose further or what to try?

  • 1
    I would check (disable) firewall/antivirus/anti-bad-weblink-scanner software. Anything that inserts itself into the pathway. Might also ensure the LAN connection is set to "work" or "home" (not "public"). Also try browsing to any web servers on the LAN (such as router admin page; printer network status page). To see if you can at least browse port 80 outside of localhost. Possibly disable "metered connection" if you have that set. – Yorik Mar 29 '16 at 21:30
  • 1
    Check if your date is set correctly. Sometimes a wrong date can mess with the security certificates. Does not sound exactly like that since it isn't warning you but wrong dates can really mess stuff up. – Lasse Halberg Haarbye Mar 29 '16 at 22:01
  • It sounds like a route issue or proxy misconfiguration. Have you looked at the internet explorer proxy settings? – Mahmoud Al-Qudsi Mar 29 '16 at 23:01
  • @MahmoudAl-Qudsi i already mentioned I did in the post – vvondra Mar 30 '16 at 10:56
0

Install Wireshark and run a session asking it to monitor the network interface in question. It'll show you all the details of all the requests and responses going out or coming in to your machine, and it'll highlight problem packets.

You can post a network capture or screenshot here if you need help interpreting the results.

0

The answer is as simple as expected.

Antivirus was responsible (ESET NOD), actually disabling protection was not enough (I tried that), it had to be removed completely.

Thanks for the tips!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.