When I remote into my computer (Win 10 Pro, Intel 6700, EVGA 960) using the Microsoft RDP server built into Win 10 Pro, everything is fine. It works normally. But when I disconnect and try to use the host computer without the RDP client, as soon as I type in my credentials, the screen goes black, only showing the cursor. The cursor can move around the screen, but it Ctrl+Alt+Delete and any other keyboard shortcuts don't have any effect.

The only solution I have at the moment is to hard restart the computer, where is starts normally and works flawlessly. But that isn't a good solution, as hard powering down a computer repeatedly isn't good for it.

Any help is appreciated and thanks in advance.

EDIT Apparently this is called a black screen of death.

  • I assume you have tried logging off the RDP session correctly by clicking Start then Log Off rather than hitting the disconnect cross on the top menu bar? – Adam Chetnik Mar 30 '16 at 20:04
  • Actually, that is the one thing that I haven't tried. I believed that when I disconnected from the program it automatically logged out. It had never been a problem until I got my new computer. I will try that. – ifconfig Mar 31 '16 at 3:50
  • It can be configured to log out off automatically however this is not set by default. – Adam Chetnik Mar 31 '16 at 8:19
  • But what if I have an in progress project that I cannot log out of my account on the host, like a video render? Will "Logging out" on the client logout the user (and it's tasks) on the host too? – ifconfig Mar 31 '16 at 13:51

As I continued to do research, I found this which informed me correctly that disabling nVidia's Shadow Play fixed the issue. (so far)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.