4

This is my first SuperUser post, so please bear with me if I make any mistakes, thanks.

I have some large database files (4-7GB) that I need to transfer to an external hard drive (WD My Book, 6TB). However, when attempting to copy the files to the hard drive, I receive the error that says The file '[my filename]' is too large for the destination file system and have to abandon the copying process. This is very annoying because I am copying from a server across an internet connection, and the copying process runs for 4+ hours before I receive the error.

EDIT: Just for clarification/details, the error has shown for at least 5 different files attempted so far.

UPDATE: As suggested, I tried copying one of the large files to my internal hard drive. This also resulted in the same error message, and my internal hard drive is also NTFS. It would appear that the external hard drive is not causing the error.

The frustrating thing is that every help topic I can find says to convert the external hard drive's FAT32 system to NTFS, but my external hard drive is already an NTFS file system.

Why does my NTFS hard drive throw maximum file size errors, and what can I do?

...

I am using Windows 7 Professional, 64-bit, 8GB RAM

...

UPDATE: Per suggestions, I tried to copy the files using robocopy, but it failed for the large files both to the external drive and to my local machine. There is an error message:

ERROR 87 (0x00000057) Copying File [my filepath]\[my filename] The parameter is incorrect.

There were smaller files that successfully copied, but it failed at 90.3% of a 4.4GB file. The robocopy command that I used was as simple as I could make it (it's my first time using it):

robocopy "[my filepath] " "[my destination path] "

So, an example with the company path names changed: robocopy "J:\Top Folder\Sub Folder\Originating Folder " "\\Client\C$\Users\doejohn\Documents\Top Folder\Destination Folder "

It seems to be something related to 4GB; but, unless I'm just flat missing something, both the external drive and my local disk are NTFS (I right-click on the drive in Explorer and go to properties, the General tab shows information about used and free space, the file system says NTFS).

  • 2
    I have no issues copying databases a hundred times that size on NTFS (which has a max theoretical file size of 16 ExoBytes, and has for years and years), so it sounds like the error message is a false positive, or you don't actually have enough freespace on the disk. Or it could be a USB problem I suppose. have you run a chkdsk /f on the usb disk recently? it may be time. – Frank Thomas Mar 30 '16 at 16:51
  • It's actually a brand new hard drive, with only about 33 GB of files copied to it already (the smaller, successful copies were first, coincidentally) – elmer007 Mar 30 '16 at 17:00
  • Did you try to copy the database file onto your internal hard drive first? Do you -- maybe -- get the same error? – daniel.neumann Mar 30 '16 at 17:01
  • @daniel.neumann That's a good suggestion, and I'm trying that now (it'll be awhile due to the connection speed). However, I'm hesitant to troubleshoot the file to intently as I have received the same error for 5 different files attempted (I started this process by selecting all the files and copying them at once, which resulted in me clicking "Skip" when the error showed, only to have the same error for every file one-by-one over the course of many hours) – elmer007 Mar 30 '16 at 17:09
  • Happened to my friend yesterday. Sounds stupid but he rebooted and was fine after that. – Austin Mar 30 '16 at 17:21
2

So, after a lot more searching (I find it difficult to locate help for specific Citrix issues), I found a Citrix help page that actually describes my issue: http://support.citrix.com/article/CTX134844. It is specifically a Citrix issue, unfortunately, and the page does not provide a solution.

As some of you noted, the magic cutoff size is 4GB, and this is just a limitation of the XenApp service we are using, regardless of the file systems in place-- the error message is not accurate.

In order to copy these large files, I believe that I will need to find some other service (like a cloud storage location) or gain physical access to the server and copy the files to an external drive there.

Thank you to everyone that helped me troubleshoot this frustrating and time-consuming problem!

|improve this answer|||||
  • The error message is accurate. The service you are using includes a filesystem that maps to the remote drive and it is that filesystem that has the limitation. – David Schwartz Oct 16 '16 at 1:46
1

First, try copying the file to your local machine like daniel.neumann said in the comments to make sure it is not a problem with the file or the network and if that works then use a program such as gparted (not sure if Windows has a built in tool for external disk formatting, Linux user here) to reformat your external as NTFS, after backing it up of course.

If that fails then there are several pieces of software that you can use to asses the health of your drive to see if there are any other problems with it.

|improve this answer|||||
  • I have updated the question with recent findings, namely that I was unsuccessful at copying a large file to my internal hard drive as well and received the same error message – elmer007 Mar 30 '16 at 20:15
  • I don't have much experience with networks but that seems to be where the problem is. Either that or you may be exceeding some sort of cache where the downloads are stored but this is just guesswork. – Kerr_Max Mar 30 '16 at 20:34
  • "reformat your external as NTFS" - it's already NTFS - as it says in the question if you read it properly. – DavidPostill Mar 30 '16 at 22:18
  • I've updated the question to include a robocopy attempt made today- still unable to copy the large files. Robocopy was successful for some files, but failed on a large one. – elmer007 Apr 11 '16 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.