7

This case is it.

[root@VIDA0 turnserver-2.6.2.1]# ./configure 
install is /usr/bin/install
pkill is /usr/bin/pkill
more is /usr/bin/more
Use TMP dir /var/tmp
Compiler: cc
Do not use -lsocket
Do not use -lwldap32
Do not use -lwldap64
Do not use -lintl
Sockets code is fine: no sin_len field present
relay threads can be used... may be...
Do not use -lcrypto
ERROR: OpenSSL Crypto development libraries are not installed properly in required location.
Abort.

and .. done.. install is failure..

What can I do about this? I searched for the error but did not get anything

2
  • What is your distro? Did you install libssl-dev before compiling? Mar 31, 2016 at 11:20
  • A good starting point is usually configure.log (or maybe it is config.log, it's been a while), which will right near the end have both the source code as well as commands and perhaps also the output that led to it concluding that your build environment has a problem.
    – user
    Mar 31, 2016 at 15:08

1 Answer 1

9

Just install the dev package of openssl which will install the headers.

if your OS is Redhat / Centos / Fedora : sudo yum install openssl-devel Ubuntu / Debian : sudo apt-get install libssl-dev

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .