0

I have a Windows 10 Pro machine set up as a kiosk. A domain account is set to auto-logon using SysInternals Autologon. http://technet.microsoft.com/en-us/sysinternals/bb963905 When the machine powers up, this account auto-logs on, and the screensaver starts, which triggers the kiosk application. This works great.

However, if I connect via RDP with another account to manage the kiosk, I get a warning that the other user will be disconnected due to the 1 concurrent session limit in Windows 10. (I know there are workarounds to allow multiple concurrent sessions, but I don't want to mess with the registry.) I go ahead and do what I need to do on the server and then sign out. At this point, the kiosk is sitting on the Windows 10 lock screen. How can I get the service account to log on again remotely so that the kiosk screensaver is triggered?

  • I would look into setting up a batch script to auto login the kiosk account when you log off. Or a .vbs – NetworkKingPin Mar 31 '16 at 14:44
  • 1
    I think the easiest way would be to simply restart the machine. There's no native way to change the current logged in user using scripts (bash, powershell) – Spokey Mar 31 '16 at 14:56
  • Related/Possible duplicate: Auto Relogon after remote access by admin – Ƭᴇcʜιᴇ007 Mar 31 '16 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.