1

Right so I'm trying to delete an empty WindowsApps folder on Windows 10. I've tried taking ownship of the folder. However whenever I try to delete the folder it says I need permisson from myself.

I've noticed on the permission entry options for my ownership is greyed out, meaning I can't select the modify option to allow me to delete the folder.

I've also tried taking ownership through the command line and it simply states Access is denied. It's obvious it's a high level OS folder, but it's empty and it's irritating.

If anyone knows how to remove this folder please let me know.

Taken ownership but still can't delete Ownership of folder, permission entry greyed out My attempt at forcing ownership through the command prompt Further evidence of a locked down folder

  • This will require you delete it outside of Windows. – Ramhound Mar 31 '16 at 22:13
  • What is the output of icacls D:\WindowsApps? Also, did you change the security settings to allow yourself Full Control after you took ownership? (Taking ownership doesn't give you as much power as you'd think.) – Ben N Mar 31 '16 at 23:08
  • @Ramhound and how might i do that? – user447436 Apr 1 '16 at 12:06
  • @BenN Well I'm not sure if you could tell me how I'd do that I could check. And the output of your command is C:\Users\Grant>icacls D:\WindowsApps D:\WindowsApps: Access is denied. Successfully processed 0 files; Failed processing 1 files – user447436 Apr 1 '16 at 12:07
  • @GR412 - What do you mean? You access the drive from outside of that installation of Windows, either on another Windows installation on the drive or another OS entirely. Its not difficult, I can't provide any more details, to such a simple task. – Ramhound Apr 1 '16 at 12:42
2

Regular non-system users (including Admins) are given Read and Execute permissions to this folder and while this can be changed for other folders, Windows will not let you modify this folder in any way.


You may own the folder, but Windows will not give you full control to the folder. For comparison I have given a picture which you attached along with screenshots of permission settings of my desktop folder:

Your Screenshot: Your Picture
My first screenshot: SCRSHT 1
My second screenshot: SCRSHT 2

Though I recommend not deleting the folder, the only possible way to do it is when Windows has not booted. You either need a pre-boot utility (there are a few for modifying SAM registries but not any for your specific purpose) or a second OS. According to me, the 'Second OS' method is better, you can get a live CD distro of almost any Linux OS and use it to do anything on your system that Windows restricts.

You may also use Unlocker to try and get rid of the folder though I doubt that it will work. Also the people over at Win SysInternals have created Handles to close bound processes (also known as handles).


Disclaimer: I take no responsiblity for any damage or harm caused due to using the above stated methods or following the above stated advice.

| improve this answer | |
  • Well that certainly answers my question, thanks a lot. Although that seems far too much hassle just to remove a single empty folder. XD – user447436 Apr 4 '16 at 0:45
  • @GR412 True. I'd prefer leaving the folder as it is. – sbrm1 Apr 4 '16 at 3:21
-1

This is the folder for all the windows apps you get in the app store, therefore, windows does not allow you to delete it. You might have apps in your start menu, but this folder is for downloaded ones. if you have downloaded things from the app store, i really don't know.

also, you may not be signed is a the admin, preventing things.

| improve this answer | |
  • I am an admin, and this is an empty folder, because i accidently changed the default storage for windows Apps to this drive. The actual windowsApps folder is back on the C drive, and this empty one on my other drive hasn't been removed. And I can't. – user447436 Apr 1 '16 at 12:09
  • @GR412 - If the drive is empty, why do you want to remove it, the folder that contains UWP has those permissions for a reason. – Ramhound Apr 1 '16 at 12:43
  • @Ramhound I don't think you understand, i accidently set the default storage location of apps into a different drive than my default C drive. I then changed it back again, so the default location is on the C drive again. Therefore it moved the contents of the WindowsApps folder back to the C drivef rom the the drive i accidently set it too. Now i'm left with an empty folder on my alternate drive. The actual WindowsApps folder with content in is on the C drive. – user447436 Apr 1 '16 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy