0

THE SCENARIO
I am using Vagrant,Windows environment and running Ubuntu inside the virtual box for my development work. I have setup an instance of Samba server and I run the I access the virtual machine through vagrant and Git Bash and run the command
net use A: \\192.168.91.11\www vagrant /persistent:no /user:vagrant
in windows cmd. This creates a virtual drive in Windows and I can access all the linux files from windows. Git related operations run fine with the Bash CLI. I want to try and setup a Git GUI like TortoiseGit.

THE PROBLEM
I am not able to see the .git folder inside the virtual drive. I have already tried to change the folder options to show hidden folders, show archives, remove the readonly on the drive, but still the .git folder remains hidden. The .git folder is visible when I run the ll command on the CLI. However it remains hidden when I access the virtual drive from windows. I wonder if there even is a way to use a gui in this setup. Excuse the long description but I need some advice here. If there is any other way to implement a GUI in this setup, I'm all ears! Thanks.

EDIT enter image description here
So I cloned my repository and on viewing the list, I see the .git folder as shows in the screen shot above.

enter image description here

But when I see the same folder in the virtual drive, it does not show up. I have already set the required properties like show archives, hidden files and unchecked readonly.

2
  • attach screenshot, how you are trying to access it?
    – SeanClt
    Apr 1 '16 at 3:35
  • Updated my post @SeanClt. Also as suggested in the below answer, I have set the hide dot files = no.
    – Aditya
    Apr 1 '16 at 6:42
0

The .git files are likely hidden by the hide dot files option on the share. It defaults to true.

Try adding a line to the share specification like:

hide dot files = false 

This should take effect within seconds after you change the configuration.

2
  • In the smb.conf file, I see the line hide dot files = no which I think means is already set to show. Tried to change it to false but to no effect. @BillThor is there a way to maybe add multiple valid users in this file. Currently it shows valid users = vagrant. Maybe I add the windows user to it?
    – Aditya
    Apr 1 '16 at 6:33
  • @Aditya valid users is a list you can list multiple users. However, valid groups may be a more appropriate way to solve that issue. You may need to use other options to set and use the appropriate permissions. Please read the man page.
    – BillThor
    Apr 1 '16 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.