I am facing a weird issue on my laptop that only Internet Explorer can access internet no other application, not even chrome, iTunes. When I try to ping any website I get an error.

Ping Error

enter image description here

When I narrowed it down, I cant even ping my gateway, which shows it could be a firewall issue, But when I open my Internet Explorer I can access every website I want.

Strangely enough when I try nslookup it works.

enter image description here

I've searched a lot on google, I've tried 1. Releasing My IP and Renewing it.

  1. Resetting winsock

  2. Resetting ipv4 logs.

  3. Disabled IPv6

  4. Pinging with IPv4 Protocol (ping -4 google.com)

  5. Deleting the saved password and reconnecting it

  6. And lot more which is written on 1st page when you google Ping General Failure windows 7 and similar searches

Why is this Happening ? Any Idea ? Please Help, this is spoiling my weekend.

EDIT 1 - Adding output of route print

enter image description here

  • This has happened to me before. Try completely resetting Internet Explorer to its default settings Apr 2, 2016 at 11:43
  • 1
    Does turning it off in Programs and Features and then turning it on help? Also, go to Internet Explorer>Internet Options and check all of your connectivity settings, specifically with trusted sites, dns, etc... Many times, improper Internet Explorer settings cause any browser except for itself to not work Apr 2, 2016 at 11:50
  • 1
    Do you have some additional firewall/security software installed? Even if you disabled the integrated windows firewall it seems you have some additional one.
    – Zina
    Apr 2, 2016 at 13:15
  • 1
    Are you connected by wire or wireless? if you have both, does it also happen on the other interface? Have you tried reinstalling your drivers?
    – LPChip
    Apr 2, 2016 at 13:31
  • 1
    Could you try a rollback through system restore? As DNS is working properly, could be a network driver issue. Is ping localhost working? Is ping <your gateway IP> working? Have you tried Safe Mode With Networking? Or a clean boot with disabled services (msconfig) to see if any of those interfere?
    – Zina
    Apr 2, 2016 at 14:14

2 Answers 2


This just happened to me, although on Windows 10.

There are a lot factors involved on this particular computer --- it is used for training and has various remote control applications installed --- but turning off Windows Defender Firewall solved the issue, at least at the operational level.

Disabling Windows Defender Firewall

Disabling Windows Defender Firewall...

Now it pings!

Now it pings!

Windows 10 Home | 1803 | 5/27/2018 | OS Build 17134.48

  • I really did not expect firewall may cause some of these ping failure problems. I tried and it was helpful in my case! Dec 16, 2018 at 11:18
  • That "General failure." can be a clue that it's the firewall! Glad it helped. Dec 18, 2018 at 22:39

I encountered this problem after configuring my firewall to block all outgoing connections save for programs I white-listed (a move to harden Win10). I could access the web unimpeeded because I white-listed Microsoft Edge and I thought I did the same for ping but it turns out Windows is tricky and has four ping programs (one in System32, one in SysWOW64, two under WinSxS) and I guess the ping I allowed (the one in System32) wasn't the ping Window called when I tried to ping from the commandline.

Anyway, I took another look at the rules to allow ping and changed it from applying to a single ping executable to apply to any program that used ICMPv4/6. That fixed ping for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.