2

I am at the point where I have no idea what I can try next after 4 hours of failing. I have tried following options enabled/disabled in ALL possible combinations:

  • Secure Boot ON/OFF
  • UEFI/LEGACY
  • AHCI ON/OFF
  • XHCI ON/OFF

I have an Acer Aspire V 15 Nitro "VN7-571G-51R8" which had Windows 10 pre-installed.

I came this far:

  • No bootable device found
  • Freez at "Starting Windows" after the "Loading Files" screen

Now, everything I try enabling/disabling in the BIOS, leads to "No bootable device found" so I guess I destroyed something? I am also trying this with 2 USB devices.

Is it possible that Windows 7 can't be installed if Acer don't want to?

2
  • this is an UEFI/GOP issue: superuser.com/a/1057484/174557 Apr 3 '16 at 16:23
  • 1
    Minor Rant. Typically its not worth the downgrade to an older version for reasons like this. There's actually a bit of a performance boost with newer versions. I'd be tempted to suggest throwing windows 7 on a VHD boot and VHD booting it with the windows 10 bootloader rather than reformatting
    – Journeyman Geek
    Apr 4 '16 at 2:33
2

Windows 7 doesn't support the new UEFI GOP (Graphics Output Protocol) and requires VGA option ROM (BIOS interrupt 10 (INT 10H)) to boot. Windows 8/10 supports GOP and read the Logo from the UEFI and displays it during boot for a smoother boot.

And it seams that your UEFI always turn GOP on and disables VGA when you select UEFI so Win7 can't be installed and hangs at Starting Windows with the graphic artifacts.

2

Given the last comment I think I can now guess about the answer:

When a motherboard with EFI firmware boots it will try to do some of these things:

  1. Load a bootloader as pointed at by previously defined EFI system variables.
  2. Optionally boot in legacy mode
  3. Failing to find bootable devices, it will scan attached devices and look for an EFI boot loader.

You are trying to install windows 7 from an USB pendrive, which means the OS is not yet installed and 1) is not the case. We can either format a pendrive with NTFS, install a legacy bootsector and set EFI to boot in legacy mode, or:

  • Keep EFI set to boot in modern EFI mode.
  • Attach a medium with a filesystem which is understood.
  • Copy a bootloader to a standarised place in that filesystem.

Now this is where I think things went wrong:

  • EFI is not required to recognise NTFS, to format the flashdrive with FAT 32
    (Technically not FAT32 but creating an EFI system partition which just happens to be 100% compatible with FAT32)
  • Place the EFI bootload at \EFI\BOOT\BOOTX64.EFI
    THIS IS NOT THE DEFAULT CASE WITH A WINDOWS 7 ISO.

Windows 7 sort of recognises EFI. The iso/DVD ships with the right driver. But it is not in the right place for a flashdrive EFI boot. You will have to find the file and manually copy it to \EFI\BOOT\BOOTX64.EFI.

Finding it is not hard. It is in the install.wim file or if you have access to an already installed windows 7 system *EFI classic install) then you can copy and rename C:\Windows\Boot\EFI\bootmgfw.efi


having done this you should be able to boot in EFI mode and start the installer. There are two more catches though.

  1. Secure boot needs to be off.
  2. Windows 7 does not ship with drivers for USB3 controllers. Many modern board ship with USB3 only (e.g. all boards on the 100-series chipsets). That means either having a driver 'disc' ready, patching the installation drive or using a PS2 keyboard. Patching the installation is probably easiest and this can be done automatically for you with tools on the microsoft website.

(All found out the hard way when I tried a clean EFI install with windows 10. Except that I also had to use an USB3 flashdrive. With an USB2 drive the win10 installer complained about a missing driver, but told me that I could ignore that error if I booted from USB or from DVD. Grah!).

4
  • Secure Boot is off, xHCI is off, Mode is UEFI, FS is FAT32, device is USB 2.0, copied bootloader of my current Win7 (same installation ISO) to the USB drive and renamed it, booted from it and now I am again stuck at "Starting WIndows" with "Microsoft Corporation" under it ...
    – Pali
    Apr 2 '16 at 23:52
  • Darn. That should have just worked. No ideas about xHCI and other modes (or if it even matters). One more idea: Do you have firewire enabled?
    – Hennes
    Apr 3 '16 at 1:03
  • I have no option to en/disabke firewire
    – Pali
    Apr 3 '16 at 10:07
  • At this point I am left without easy solutions. (non easy: install on another PC and move disk at first reboot or sysprep, but there should be something a lot easier).
    – Hennes
    Apr 3 '16 at 10:18
1

Let's start clean to avoid any errors. Use the official Windows DVD/USB Download tool to freshly mount your DVD/.iso onto the USB stick. This will also verify that there are no major integrity errors with the image. This can and will happen, so it's best practice to use the tool. http://wudt.codeplex.com

With Windows 7 and the WUDT, use BIOS/Legacy mode instead of UEFI. Enable CSM, enable AHCI, but disable Secure boot. Set VGA as legacy/default if given the option. You can choose whether to enable XHCI, but you should use a USB 2.0 port for the install for maximum compatibility either way. If the install fails, disable XHCI until Windows is installed.

If you want to use UEFI, you will need to use a 64bit copy of Windows and install with GPT partitioning, not the WUDT. The rest of the settings above apply.

During bootup, select the USB drive as your boot device. If you are not prompted to do so or the option is not displayed on your POST screen, you can manually select it in the BIOS.

After you've run the primary setup, return the BIOS to use the HDD as the boot device.

If the above fails, you may need to change some configurations to make the drive UEFI bootable for your system. Now that you've verified your image passes the built in checks of the Windows USB tool, you can follow the tutorial here to use Windows tools to make a bootable stick for your installation. I recommend 7-Zip as an archiving program, if you do not have one already.

http://www.nextofwindows.com/how-to-make-uefi-bootable-usb-flash-drive-to-install-windows-8

If your image is the culprit, you can download a new one and use your product key with it. Direct download from Microsoft here: https://www.microsoft.com/en-us/software-download/windows7

12
  • my laptop has only USB 3.0 ports. one question: has the USB device to use GPT in order to be detected by UEFI? Becuase UEFI only detects GPT devices, if the USB is MBR my laptop (UEFI) won't detect it?
    – Pali
    Apr 3 '16 at 12:16
  • I tried the "official Windows DVD/USB Download Tool" without any integrity errors but my USB is not even detected by my laptop (UEFI, Secure Boot OFF, xHCI ON or OFF) ...
    – Pali
    Apr 3 '16 at 12:29
  • Although I have been able to use the WUDT to install to BIOS and UEFI systems, you can follow the second link I provided to make your USB drive GPT partitioned for a UEFI specific install. You can ususally disable XHCI to make your USB 3.0 ports revert to 2.0 standards for compatibility. Optionally, there are some workarounds to make a USB 3.0 installation drive. Though I recommend doing the above for a 2.0 install, at a glance, this guide here seems to hit all the points. codeabitwiser.com/2014/03/…
    – Raj Huff
    Apr 3 '16 at 12:34
  • You said that your USB is not detected by your laptop. But it was detected by another computer which installed the Windows setup to the drive? Is that with UEFI on? Do you have administrative access to the computers BIOS, or is this e.g. a company owned machine?
    – Raj Huff
    Apr 3 '16 at 12:38
  • it's my own laptop. Following scenarios: USB drive uses MBR = not detected by UEFI, USB drive uses GPT = detected by UEFI.
    – Pali
    Apr 3 '16 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.