0

I used:

yum -y --nogpgcheck install devtoolset-3-gcc devtoolset-3-gcc-c++

to upgrade gcc and g++ from 4.4.7 to 4.8+

it installed :

devtoolset-3-gcc-4.9.1-10.el6.i686 
devtoolset-3-gcc-c++-4.9.1-10.el6.i686

When I tried gcc -v I received my previous version:

gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC)

When I tried to install gcc-4.8.0 , from source code I received error:

configure: error: Building GCC requires GMP 4.2+, MPFR 2.4.0+ and MPC 0.8.0+.

I checked that I have all requires installed.

How do I upgrade?

1

It was helping:[root@centos66a Stazene]# scl enable devtoolset-3 bash

gcc version 4.9.1 20140922 (Red Hat 4.9.1-10) (GCC)

1
0

I think the packages provide GCC in another command not to conflict with original GCC. Type command below to know commands the packages provides:

$ rpm -ql devtoolset-3-gcc-4.9.1-10.el6.i686 | grep bin
1
  • [root@centos66a Stazene]# rpm -ql devtoolset-3-gcc-4.9.1-10.el6.i686 | grep bin /opt/rh/devtoolset-3/root/usr/bin/cc /opt/rh/devtoolset-3/root/usr/bin/cpp /opt/rh/devtoolset-3/root/usr/bin/gcc /opt/rh/devtoolset-3/root/usr/bin/gcc-ar /opt/rh/devtoolset-3/root/usr/bin/gcc-nm /opt/rh/devtoolset-3/root/usr/bin/gcc-ranlib /opt/rh/devtoolset-3/root/usr/bin/gcov /opt/rh/devtoolset-3/root/usr/bin/i686-redhat-linux-gcc Apr 4 '16 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.