0

I am trying to synchronize my clock with a NTP server by following the instructions here http://support.ntp.org/bin/view/Support/GettingStarted , but this works only with some connections, not with others.

I am on Mac OS X El Capitan 10.11.2, and I am using a WIFI connection (A). I picked server ntp.your.org and I synchronize my computer with it:

$ sudo ntpdate -b ntp.your.org
31 Mar 20:05:04 ntpdate[43114]: step time server 204.9.54.119 offset -0.005629 sec

$ ntpdc -c peers
nodename nor servname provided, or not known

$ ntpq -pcrv
 nodename nor servname provided, or not known

On the other hand, if I do the same by switching my internet connection to a different WIFI network (B), I get a different output:

$ sudo ntpdate -u -b ntp.your.org
 3 Apr 18:22:07 ntpdate[1186]: step time server 204.9.54.119 offset 0.153946 sec   

$ ntpdc -c peers
     remote           local      st poll reach  delay   offset    disp
=======================================================================
=ntp.your.org    172.20.10.4      1   64    1 0.15540  0.158759 2.81735

$ ntpq -pcrv
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 ntp.your.org    .CDMA.           1 u    9   64    3  140.650   -1.642 160.401
associd=0 status=c012 leap_alarm, sync_unspec, 1 event, freq_set,
version="ntpd 4.2.6@1.2089-o Fri May 28 01:20:53 UTC 2010 (1)",
processor="x86_64", system="Darwin/15.2.0", leap=11, stratum=16,
precision=-20, rootdelay=0.000, rootdisp=1.140, refid=INIT,
reftime=00000000.00000000  Mon, Jan  1 1900  0:09:21.000,
clock=daabc1ea.c9fead6c  Sun, Apr  3 2016 18:23:06.789, peer=0, tc=3,
mintc=3, offset=0.000, frequency=-47.221, sys_jitter=0.000,
clk_jitter=0.001, clk_wander=0.000

I previously posted this question here, and the answers pointed out that this may due to the fact that port 123/UDP might be blocked when using A. In this regard, here is a snapshot of the port settings for connection A

enter image description here

As you can see, I enabled NTP on port 123 in both directions (line 9 and 22). However, I still get the errors above when using connection A.

Do you have any solution in mind?

  • can you open port 123 without a source port? e.g so its the same as all the other entries? – user3788685 Apr 3 '16 at 17:14
  • 1
    Welcome to Super User. You can freely edit your own posts but for your protection, this must be done under the original user account. It looks like you have created a second account, which will also interfere with your ability to comment within your thread and to accept an answer. See Merge my accounts to get your accounts merged, which will solve the problem. – fixer1234 Apr 3 '16 at 18:51
0

you should provide more informaiton about your Wi-Fi setup. Normally, these kinds of problems occur when connecting Wi-Fi routers in "WAN cascade fashion" that is, first Wi-Fi router with WAN port towards Internet and then second Wi-Fi router wiht WAN port connected to the LAN that is, the WAN port of the second router connected to one of the free ports (switch ports) of the first router. If that is your case, try avoid connecting anything on the WAN port of the second router that is, both router should be interconnected thru switch ports; the DHCP server on the second router should be deactivated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.