1

I'm running Windows 10 Pro on an SSD. Whenever I turn on my computer, File Explorer opens up. It's a nuisance and I'd rather not have it open at every startup. I've checked article upon article and everything seems normal. My registry keys for Userinit are normal, Shell is normal, and restore folders upon startup is not on. It's almost like Explorer is being told to open twice, but I can't find where the problem is. The Startup folder doesn't contain explorer.exe either.

The programs I have running in the Startup folder: Killer Network Manager; and the programs I have running on boot are: Delayed launcher (Intel), IAStorIcon (Intel Rapid Storage Technology), Java Update Scheduler, NVIDIA Backend, NVIDIA Capture Server Proxy, System Control Manager (SCM), and Xear Audio Center.

Any ideas? If anybody needs more info about my PC, ask in a comment. I do have a secondary drive (an HDD.)

2
  1. Try Sysinternals Autoruns to view all startup loactaions at once (some are obscure).

  2. Try starting in Safe mode, which disables almost all startup applications (some antivirus products may still start). Then run one of the Autoruns items at a time (e.g. IAStorIcon) to see if it invokes Windows Explorer.

  • Thanks for showing me that program! For some odd reason, there were two files being autorun under my D:/ drive... but that's my optical drive. I unchecked both of them, and File Explorer no longer opens at startup. Perhaps Windows was looking for those files, but it couldn't find them, so it opened File Explorer. – Mark Schauer Apr 3 '16 at 21:09
0

Before doing all the stuff suggested check for an installed program and not windows. For instance Google drive has an option under the advanced tab to Start Google drive on system startup. This causes the File Explorer to open to the Google Drive folder on system startup. If you don’t use Google drive, you need to check to see if any other installed program might do the same thing. Take note of which drive is opened on system startup. That is how I figured out that it was Google drive giving me the trouble. I heard Adobe products might cause it. Image

Google Drive folder preferences

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.