4

After a random amount of time after reboot (20 minutes to 2 hours), my laptop would have considerable lag, locking up for 2-3 seconds every 6-10 seconds. I tried to follow What is the cause of a high CPU usage of 'system and compressed memory' in Windows 10? because the symptoms were similar, but the root cause was different.

Observing Task Manager during these lockups, 'System and compressed memory' would be the only thing spiking and would reach about 25% before returning to a negligible level. Following what magicandre1981 did in the other thread, I used WPRUI to capture the activity and opened it in WPA. I drilled down the CPU spikes through ntoskrnl.exe -> ndis.sys -> rt640x64.sys. Looking up that driver, it was for the onboard NIC (Realtek).

Updating to the latest drivers from Dell didn't help. Since it's a laptop and I'm not likely to use the wired NIC anytime, I just disabled it in Device Manager, and the problem stopped immediately.

I thought I'd type this up since I spent so much time researching the problem. Big thanks to @magicandre1981 for his work in the other question and for leading me towards WPRUI and WPA.

WPA Sreenshot

3
  • @hennes curious, why did you remove the realtek tag? the culprit was realtek drivers. Apr 4, 2016 at 18:56
  • Seemed to match the idea of these. meta.superuser.com/questions/8402/… Not really sure why it is not on that list. Now [realtek-network] or [realtek-audio] I could understand, but [realtek] (the firm) seems just as broad as those deprecated tags.
    – Hennes
    Apr 4, 2016 at 19:15
  • That makes sense. If I had privs to add a proper tag I would Apr 4, 2016 at 19:37

1 Answer 1

1

Updating to the latest device drivers is the first step. If that doesn't work, disable the onboard wired NIC (Realtek PCIe FE Family Controller) in Device Manager, and the problem should stop immediately.

8
  • 2
    It is an answer...
    – Moab
    Apr 4, 2016 at 1:25
  • 2
    This was the answer to the question. Apr 4, 2016 at 1:25
  • @JonnyBlaze If this answers your question, mark it as the accepted answer. (Although the first sentence should be moved to your question.) If this is not an answer, but instead an extension to your question, update your question with this information and delete this answer.
    – Ouroborus
    Apr 4, 2016 at 2:39
  • @Ouroborus I can't for 2 days, I tried. The first sentence is in the question already. Plus the first sentence is information that may be able to help someone else, and it's the first thing they should try. Apr 4, 2016 at 2:43
  • What confused me, is the first sentence, it has no business being in the answer.
    – Ramhound
    Apr 4, 2016 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.