4

This question already has an answer here:

TL;DR version:

I am on Linux, manual downloads gives me v11.2.202.577, official repo gives me 11.2.202.569.

Is my copmuter brokened and how do I fix it?


I'm trying to update Flash for Linux using my OS's package manager, and it fails to provide me an up-to-date version (up-to-date as in the 11.2 version tree, I know Flash for Windows latest version is 21, I expected dnf to provide me with Flash 11.2.202.577)

If I visit the official download page, I can download the binary for 11.2.202.577, so Adobe is still offering 11.2 backports. But the repo apparently is stuck at 11.2.202.569.


Detailed version

Performing dnf update --verbose gets me:

cachedir: /var/cache/dnf
Loaded plugins: migrate, noroot, debuginfo-install, Query, download, protected_packages, reposync, config-manager, builddep, system-upgrade, copr, playground, needs-restarting, generate_completion_cache
DNF version: 1.1.6

(... other repos ...)

repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 22 - Free
not found updateinfo for: RPM Fusion for Fedora 22 - Free

(... other repos ...)

repo: using cache for: updates
Russian Fedora for Fedora 22 - Free - Updates                                                                                 123 kB/s | 140 kB     00:01    

(...)

adobe-linux-x86_64: using metadata from Tue Mar  1 17:13:54 2016.
rpmfusion-free: using metadata from Wed Aug  5 09:49:43 2015.

(...)

updates: using metadata from Sun Apr  3 18:07:09 2016.

(...)

Last metadata expiration check performed 0:00:00 ago on Mon Apr  4 15:02:47 2016.
Completion plugin: Generating completion cache...
--> Starting dependency resolution
---> Package bind-libs.x86_64 32:9.10.3-8.P3.fc22 will be upgraded
---> Package bind-libs.x86_64 32:9.10.3-9.P4.fc22 will be an upgrade

(...)

---> Package chromium.x86_64 1:49.0.2623.108-1.fc22.R will be upgraded
---> Package chromium.x86_64 1:49.0.2623.110-1.fc22.R will be an upgrade
---> Package chromium-libffmpeg.x86_64 1:49.0.2623.108-1.fc22.R will be upgraded
---> Package chromium-libffmpeg.x86_64 1:49.0.2623.110-1.fc22.R will be an upgrade

(...)

--> Finished dependency resolution
Dependencies resolved.

Performing dnf clean all and then dnf update causes a lot of data fetching to occur, including from the adobe repo, but it still displays the same date (Mar 1 17):

(...)
Adobe Systems Incorporated                                                                                                    3.1 kB/s | 1.8 kB     00:00    
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
(...)

adobe-linux-x86_64: using metadata from Tue Mar 1 17:13:54 2016.

Repository details

$ cat /etc/yum.repos.d/adobe-linux-x86_64.repo 
[adobe-linux-x86_64]
name=Adobe Systems Incorporated
baseurl=http://linuxdownload.adobe.com/linux/x86_64/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux

http://linuxdownload.adobe.com/ gives me 404

http://linuxdownload.adobe.com/linux/x86_64/repodata/repomd.xml is:

<repomd>
  <data type="other">
    <location href="repodata/other.xml.gz"/>
    <checksum type="sha">8a3454cf049cac24d0cec354d129ab89b4fdf5ce</checksum>
    <timestamp>1456863234</timestamp>
    <open-checksum type="sha">7745898d3eddf4692293413d8a29cb9e3ffcd843</open-checksum>
  </data>
   <data type="filelists">
        <location href="repodata/filelists.xml.gz" />
        <checksum type="sha">7b54b465547eb400102607b9d22922bb52d52705</checksum>
        <timestamp>1456863234</timestamp>
        <open-checksum type="sha">21eab3d4f0f8b03c642c71e544772e70957a5718</open-checksum>
    </data>
    <data type="primary">
      <location href="repodata/primary.xml.gz"/>
        <checksum type="sha">b42e0ca15e52334cd62d04fe95ffbc4547f13641</checksum>
          <timestamp>1456863234</timestamp>
          <open-checksum type="sha">3e36f0867eece5ee02a3040b78160ed271e9ee69</open-checksum>
    </data>
</repomd>

Interestingly, 1456863234 Unix Time is Tue, 01 Mar 2016 20:13:54 GMT and 01 Mar 2016 17:13:54 BRT

Detailed details

I'm running Firefox on Fedora 23 and I've been getting the security alert for an outdated Flash version for quite a few days now:

enter image description here

If I open the about:plugins page, I get the following information (notice the part where it says (STATE_VULNERABLE_UPDATE_AVAILABLE):

Shockwave Flash

Arquivo: libflashplayer.so
Caminho: /usr/lib64/mozilla/plugins/libflashplayer.so
Versão: 11.2.202.569
Status: Ativo (STATE_VULNERABLE_UPDATE_AVAILABLE)
Shockwave Flash 11.2 r202

Visiting the about:addons page also shows me a security alert:

enter image description here

Clicking the "Update now" link opens https://blocklist.addons.mozilla.org/en-US/firefox/blocked/p1138, which states "Flash Player Plugin on Linux 11.2.202.559 to 11.2.202.569 (...) have been blocked on March 18, 2016" and has a link to the Mozilla Plugin Check page.

That page also says I have Flash 11.2 r202 (11.2.202.569) and displays an "update" button linking to http://www.adobe.com/go/getflashplayer. enter image description here

The Adobe Flash Player download page says the latest version is 11.2.202.577. It correctly detects I'm on Linux 64-bit pt-br Firefox, and offers me a few download choices.

If I choose .rpm, it allows me to download the binaries in an .rpm package. I do, howeber, prefer to use the package manager (in my case. dnf with a yum compatibility) to get my updates.

If I download the "YUM package" and rpm -i the file, it says I already have it installed. Removing adobe-release-x86_64-1.0-1.noarch and then reinstalling the file produces the same result.

marked as duplicate by That Brazilian Guy, DavidPostill, Community Apr 5 '16 at 15:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Adobe removed support for Linux version of flash about a year ago. Most users either switch to Chrome and use pepper flash, or switch to HTML 5 – Sergiy Kolodyazhnyy Apr 4 '16 at 19:11
  • @Serg Ok, then how can I download the binary for 11.2.202.577 but the repo apparently is stuck at 11.2.202.569? – That Brazilian Guy Apr 4 '16 at 19:16
  • get.adobe.com/flashplayer for me shows the 577 version , perfectly fine tried that ? – Sergiy Kolodyazhnyy Apr 4 '16 at 19:23
  • @Serg it shows me the same, as stated in the question. – That Brazilian Guy Apr 4 '16 at 19:24
  • 1
    What? No, I can download the package fine. I just don't want to use manual download methods, I prefer using the repositories. It's the Linux world after all, right? If I wanted manual downloads I'd have stayed on Windows! ;P – That Brazilian Guy Apr 4 '16 at 19:29
4

Ok, turns out the repository is providing the correct version and it's a Firefox issue. One I had already noticed more than a year ago: Firefox incorrectly detects the Flash version based on the pluginreg.dat file on the Firefox profile folder.

Not the answer you're looking for? Browse other questions tagged or ask your own question.