12

I cannot copy and paste text from my Mac (host) to my Ubuntu Server (guest) in Virtualbox.

Solutions I tried:

  • Enable Bidirectional in Advanced Settings for "Shared Clipboard" and "Drag'n'Drop". Reboot VM.
  • Look for a Guest Additions iso for Mac, but none exists.

Neither solution solved the problem. What's wrong?

  • It's strange that such a simple thing as sending a few keystrokes from the host machine into the virtual machine seems to be impossible. – Gruber Aug 30 '16 at 7:36
  • @Gruber Agreed - VirtualBox should enable this by default. – flow2k Feb 24 at 2:35
8

There are no guest additions for Mac because macOS is not supported to be run as a guest in a virtual machine on a system other than macOS. In your setup, Ubuntu is the guest system and macOS is the host system.

The guest additions are to be installed in the guest system. Just start your Ubuntu virtual machine and select Devices -> Insert Guest Additions CD Image from the VirtualBox command menu to install the guest additions into Ubuntu. After that, copy and paste should work, provided that you activated it in the settings as you described.

  • Had to sudo apt-get gcc make perl first. After that it worked! – flow2k Feb 24 at 2:35
  • 1
    You might need to restart the VM in order for this to take effect. – nbro Feb 28 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.