0

With syntax on inside .vimrc (that's the only line in my .vimrc file), opening a file with any sort of syntax highlighting will cause

Vim: Caught deadly signal SEGV

Vim: Finished.
Segmentation fault

If I created a new file, i.e., vim test.py, then simply type one of these characters: # ' " @ \, the above error would immediate happen along with Vim: preserving files.... Or indeed if I type anything that will trigger a syntax highlighting would cause the segmentation fault. Hence typing code such as if will also crash Vim.

I don't have sudo, hence I have to build it myself. The compilation steps:

git clone https://github.com/vim/vim.git
cd vim
./configure --prefix=$HOME/local --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-python3interp --enable-perlinterp --enable-luainterp
make
make install

Vim version output vim --version:

VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Apr  5 2016 01:08:47)
Included patches: 1-1710                                          
Compiled by ...                                       
Huge version with GTK2 GUI.  Features included (+) or not (-):    
+acl             +farsi           +mouse_netterm   +tag_binary    
+arabic          +file_in_path    +mouse_sgr       +tag_old_static
+autocmd         +find_in_path    -mouse_sysmouse  -tag_any_white
+balloon_eval    +float           +mouse_urxvt     -tcl
+browse          +folding         +mouse_xterm     +terminfo
++builtin_terms  -footer          +multi_byte      +termresponse
+byte_offset     +fork()          +multi_lang      +textobjects
+channel         +gettext         -mzscheme        +timers
+cindent         -hangul_input    +netbeans_intg   +title
+clientserver    +iconv           +packages        +toolbar
+clipboard       +insert_expand   +path_extra      +user_commands
+cmdline_compl   +job             +perl            +vertsplit
+cmdline_hist    +jumplist        +persistent_undo +virtualedit
+cmdline_info    +keymap          +postscript      +visual
+comments        +langmap         +printer         +visualextra
+conceal         +libcall         +profile         +viminfo
+cryptv          +linebreak       +python/dyn      +vreplace
+cscope          +lispindent      +python3/dyn     +wildignore
+cursorbind      +listcmds        +quickfix        +wildmenu
+cursorshape     +localmap        +reltime         +windows
+dialog_con_gui  +lua             +rightleft       +writebackup
+diff            +menu            +ruby            +X11
+digraphs        +mksession       +scrollbind      -xfontset
+dnd             +modify_fname    +signs           +xim
-ebcdic          +mouse           +smartindent     +xsmp_interact
+emacs_tags      +mouseshape      +startuptime     +xterm_clipboard
+eval            +mouse_dec       +statusline      -xterm_save
+ex_extra        +mouse_gpm       -sun_workshop    +xpm
+extra_search    -mouse_jsbterm   +syntax

OS info:

SUSE Enterprise
Linux 3.0.101-68-default x86_64
KDE: 4.3.5

I obviously cannot work with vim without syntax on, so I'm hoping to fix this problem. Is there something wrong with my build steps? The one built in on the system works, but it's only 7.3 and lack pretty much all the most useful features such as python, lua, ruby and clipboard.

Edit:

Tried with --noplugin, same problem.

Tried compiling it again with no extra features, i.e., ./configure --prefix=$HOME/local && make && make install, same problem.

  • What happens if you invoke vim with the --noplugin argument? If it fails to crash, you need to isolate which plugin is the culprit, then probably mail the vim-dev mailing list with a bug report. – Heptite Apr 5 '16 at 2:47
  • @Heptite I've just tried that and it still the same crash. I've also just tried compiling it without any extra features, i.e., ./configure && make && make install and it's still the same. I guess I should email vim-dev anyway. – Nelson Yeung Apr 5 '16 at 17:18
  • I have the same patch level, but I can't get it to crash. Any way you can narrow down how to reproduce it would help the dev's a lot. – Heptite Apr 5 '16 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.