3

I'm trying to install Ubuntu or Debian from a live usb, but I can't get past the grub screen. I have two physical USB drives and I used unetbootin to create the live usbs. I've tried the live USBs on my other (4-year-old) laptop and they work fine there.

I tried with Ubuntu 14.04, Ubuntu 16.04 Beta 2, Debian stretch, and Ubuntu 15.10. Ubuntu 16.04 and Debian stretch were the most successful - I can get as far as the screen where you select what type of installation you want to do. For Ubuntu, this is a grub screen, and for Debian it looks like a stylized grub screen with a Debian background. Once I select an option (graphical install, install, try Ubuntu without installing...), the screen goes black and stays that way. The display backlight is still on, the screen is just all black.

Laptop specs:

  • ThinkPad X1 Carbon 4th Generation
  • Intel Core i7-6600U Processor (4MB Cache, up to 3.40GHz)
  • 14.0 WQHD(2560 x 1440) IPS Non-Touch
  • 16GB LPDDR3 SDRAM 1866 MB
  • Intel HD Graphics 520
  • 512 GB Solid State Drive PCIe-NVMe

Potential problem areas:

  • Secure boot (I disabled it in the BIOS)
  • UEFI (it's enabled, with CSM support), Legacy boot fails even harder
  • New skylake processor
  • High res display

I've searched around considerably, and it looks like I may need to set some kernel parameters, but I'm not sure what (I've blindly tried a couple things I saw, but to no effect). Any thoughts on what's going on or what I can do to fix it? Is there a distro/build with a kernel version more likely to support my hardware?

1

1 Answer 1

1

I found great troubleshooting steps in this monster thread: http://ubuntuforums.org/showthread.php?t=1743535, and thanks to Robert Rowntree for this link, which was essential. Here's what I did:

In the grub screen, I typed "e" to edit the "Graphical Install" entry. Then I turned this line:

linux    /install.amd/vmlinuz vga=788 --- quiet

to

linux    /install.amd/vmlinuz vga=788 nosplash --verbose text

That gave me some text output, which showed that the kernel boot got hung up on a line about intel_pstate="HWP" (or something). Based on the link from Robert Rowntree, I restarted and this time changed that same line to:

linux    /install.amd/vmlinuz vga=788 nosplash --verbose text intel_pstate=no_hwp

That got me in to the graphical install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.