0

Basically I have this software that only validates my key if it's installed on the main drive (where the license is located in appdata). I have to install my files on the C, which i don't want.

So I want to make a mklink.

I know the default location it wanted to install in, so I installed it elsewhere instead and tried to make a link to the original place it would prefer the files to be in.

C:\Steinberg\vstplugins is the location it "should" be in

F:\whatever\newplace is the location I installed it in (where I want to be running the application from). Then I run this

mklink /D C:\Steinberg\vstplugins F:\whatever\newplace

If my understanding is correct, the first is the link, the 2nd is the target (where I want the link to point to)

If I also understood correctly, the link shouldn't already exist, otherwise it throws a file already exists error.

So the C:~~~ doesn't even exist right now.

Then I run that code, I get the error that the system cannot find the path file. I tried reversing the link and target. I tried having both folders exist and deleting the one in C: (obviously need to keep the one in my F drive). I tried as I said reversing the link and target in the query. At this point i'm lost. This is pretty frustrating as this should be super simple, but something is evading me that i'm not understanding through documentation, nor other posts.

Help...please? :(

1
  • Does the parent, C:\Steinberg, exist?
    – user1686
    Apr 5 '16 at 5:09
0

It's likely not working because the parent directory does not exist. Anyhow, even if you get the symbolic link working, the application might still have issues, as the old path might still be referred in the Registry all other places.

The best approach would be doing the following:

  1. Remove the application
  2. Delete both C:\Steinberg\vstplugins and F:\whatever\newplace
  3. Install the application into the default location (C:\Steinberg\vstplugins)
  4. Run ROBOCOPY /COPYALL /E /MOVE C:\Steinberg F:\Whatever
  5. Run MKLINK /J C:\Steinberg F:\Whatever
1
  • This worked good sir. Appreciate the clear and concise answer.Thanks!
    – Denis
    Apr 12 '16 at 2:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.