0

I have a Dell Inspiron N7110 laptop originally running Windows 7 Home Premium SP1 (64-bit). Everything was fine and reliable on it with Win 7. When I upgrade the system to Windows 10 Home, everything seems fine at first when the Windows 10 Desktop first appears. Full Internet access in both Internet Explorer and Google Chrome. But that lasts only until the first time that I restart the system following the upgrade. Once the system restarts, and the Windows 10 Desktop reappears, I suddenly lose all Internet access.

Note that this is not a Wi-Fi problem. I lose Internet access on the system regardless of whether I'm connecting via a wireless network, or via an Ethernet cable plugged directly into the router. The really weird part is that the Network icon in the Taskbar Notification Area shows a status of "Internet access". However, when I open a browser, or any other application that tries to go online, the program will report that there's no connection.

During the Windows 10 upgrade process, I've tried using custom settings, as well as the default "Express settings"; but both methods produce this same result.

The only way I've found of fixing the problem is by using the Recovery option to "Go back to Windows 7". Once I undo the Windows 10 Upgrade, and get the system back to Windows 7, everything works fine again. I can restart the system as often as I want with Win 7, and never lose Internet access.

This problem is very repeatable.

•Win 7: Internet access OK.

•Win 10: Internet access OK immediately following the upgrade.

•Win 10: After the first restart, no more Internet access.

•Win 7: Internet access OK again after downgrading back to Win 7.

I've tried using the Troubleshooter to "Troubleshoot my connection to the Internet"; and it does detect a problem. It reports the following message:

The remaining repairs require administrator permissions Problems found: One or more network protocols are missing on this computer

I click the option to "Try these repairs as an administrator"; and I get a progress bar while it says that it's fixing the problem. And after a minute or so, it claims that the problem is "Fixed" -- at least that's the status it reports. But once I close the Troubleshooter and open a browser window (whether IE or Chrome), the browser still can't connect with any websites. And, of course, this whole time the Network icon in the Notification Area continues to indicate that I'm connected with "Internet access".

UPDATE: I also checked and confirmed that IPv4 and IPv6 protocols are enabled on both the Wi-Fi and Ethernet adapters.

In looking thru the System Event Log, I did come across an Error entry that seemed to correspond to the restart times when I lose Internet access. The entry I'm seeing there is as follows:

Event 7001, Service Control Manager The NetTcpActivator service depends on the NetTcpPortSharing service which failed to start because of the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

So I then checked Services; and I did find that NetTcpPortSharing service, as well as NetTcpActivator, were not running. And the NetTcpPortSharing service was set to Disabled. So I set NetTcpPortSharing to Automatic. Then restarted the system again. Both of these services -- NetTcpPortSharing and NetTcpActivator -- are now running OK. And the Event 7001 error is no longer showing up.

However, even after making the above change, the system still has no Internet access (despite what the Network icon says).

I'm at the point where I'm ready to just give up on this Windows 10 Upgrade altogether; and just permanently go back to Windows 7. Has anyone else seen or heard of a problem like this? Any idea what's going on here?

  • Possible duplicate of No internet connection after upgrade to Windows 10 – CharlieRB Apr 5 '16 at 12:31
  • I don't believe my issue is a duplicate of what you're referencing. That posting says that there was no Internet access at all after upgrading. In my case, there IS Internet access after upgrading; however, access goes away later after the system restarts. Also, your posting is regarding a problem exclusively with the Wi-Fi connection. My problem is with not just Wi-Fi but also with the Ethernet connection. Finally, that other issue got fixed by re-enabling IPv4 and IPv6. Those protocols are already enabled in my case. So my issue appears to be different from the one you referenced. – Tom-T Apr 5 '16 at 21:03
0

Well it looks like I figured out what was wrong here. Basically, my Dell Inspiron N7110 laptop is simply not compatible with Windows 10.

I finally got around to checking the Dell website. It's something obvious that I probably should have done right up front. On the support page for the N7110, Dell actually makes the following statement about this particular model laptop:

Product not tested for Windows 10 upgrade. Dell is not testing or developing Windows 10 drivers for this product. If you choose to upgrade, some features, applications, and connected devices may not work as expected.

I guess the reason I didn't bother looking to the Dell website right up front was because I ran the Microsoft Windows 10 System Compatibility Report on this system and I naively accepted the result that said "Your system is compatible". Apparently users should NOT rely on Microsoft to determine whether or not a system is compatible with Windows 10. Always check with the system OEM to see what they have to say about upgrading.

So, in my case here, it looks like I'll be staying with Windows 7 permanently -- at least on this computer. Thanks a lot, Microsoft, for letting me waste several days trying to troubleshoot this problem that YOU created when you explicitly told me (via your "Compatibility Report") that it was OK to upgrade this system. WRONG!

0

You may be able to force installs of the Win7 network drivers and replace the newer drivers provided by Win10. Then make sure you don't ever do the Windows provided optional driver updates included in windows update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.