0

I recently built a new machine as a lab workstation. It has two Xeon processors running on an asus z10pe motherboard and an Nvidia gtx 750ti graphics card.

At the moment, I haven't been able to get the graphics card drivers to do anything other than this:

So far, I have tried two different approaches to installing the graphic card drivers:

  1. Installing directly from the respositories (nvidia-352)
  2. Using the installer from nvidia's website

I am puzzled by the results. Both end up having the screen corrupted ( not sure if thats a good way to describe it, but it looks the framebuffer is not completely cleared out)

enter image description here

What am I missing?

  • That looks like a monitor sync problem. What kind of cable are you using to the monitor? Have you tried a different monitor? What happens if you use the OS's default drivers? (btw, it's "Xeon". Xenon is an inert gas) – Jamie Hanrahan Apr 6 '16 at 0:58
  • Xeon :) Thanks for pointing that out. For some reason, my brain has mapped it out to the inert gas. I checked it by using different monitors, the first one is connected to the card using a hdmi cable and the second one with a regular vga cable. I was able to boot to X with the default drivers. Its only after I installed the nvidia drivers that I started having this issue. – feverDream Apr 6 '16 at 6:18
  • The 750ti is hardly a new chip so you'd think the drivers would be good by now. It's possible the card is defective - it happens (and it's possible for defects to not show up until you load a chip-specific driver). Have you tried the card in a Windows machine, or tried putting Windows on this machine, just as a test? The Windows drivers definitely work (I've had a 750ti in my Windows ws for quite a while) so if it doesn't work there, it's likely the card. Then again... are there other (maybe older) versions of the driver you can try? Also, how's the power to the card? A beefier PSU might help. – Jamie Hanrahan Apr 6 '16 at 9:10
  • It's not a solution, but most of the times I have tried Nvidia official drivers (2x 750m card, SLI) I ended up reinstalling the whole system. It worked only once (specific version of kernel and driver), rest of the time I had similar results as you. Nouveau drivers (the open source ones, which probably come with your distro) are poor, but at least they work, the official Nvidia drivers for Linux are a gamble. Didn't check the status for a year now, but seeing your question it haven't really changed – Adalee Apr 6 '16 at 12:58
  • @JamieHanrahan Hmm, I haven't thought of that. The screen corruption happens on my laptop too. A quick fix is to add nomodeset to the kernel parameters. Installing the nvidia drivers with the right xorg.conf works. Here its the opposite. Anyways, I am planning on testing the gpu on a friends machine and see what happes. In the meantime, I will just put and older card and get to work :) – feverDream Apr 6 '16 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.