1

I'm getting VERY slow transfer speeds with 3 different usb flash drives on different computers. This are the aspects I consider relevant:

  • USB 3.0 driver is installed
  • USB 3.0 is enabled from BIOS
  • Windows 8.1 as OS
  • USB 2.0 flash drives
  • USB legacy enabled and disabled (same result)
  • File size range from 50 mb to 200 mb
  • Flash drive formatted as FAT32 (16kB cluster)
  • Flash drive plugged to 3.0 and 2.0 ports (same result)
  • GA-Z170X-Gaming G1 motherboard
  • Intel core i7 4790K 4.0Ghz processor
  • Flash drive: Verbatim 32 gb 2.0

Now the awful: I'm getting 20 kB/s - 2mB/s Speeds. Most of the time 50kB/s

What is going on here!? I've tried EVERY SINGLE solution out there, and still. I need some external help here.

Another important aspect. All 3 of my flash drives were fine until I used them in my college lab computers. Those computers have Admin rights for engineers and I'm not sure if something such as a virus can damage an USB this way.

  • have you enabled the write cache in device manager? – magicandre1981 Apr 6 '16 at 15:52
  • Yes. Still, nothing. – AFP_555 Apr 7 '16 at 3:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.