I am trying to share a folder on my Windows 10 machine. The computer is connected to the network via Ethernet. The problem is that when I try to access this shared folder from another Windows computer, I get an error saying that "Windows cannot access \\xxxxx" with an error code 0x80070035 (Network path was not found).

Now, if on the Windows 10 machine I turn the firewall off, the share can be accessed by the other computers with no problem. So this narrows down the problem to the firewall settings.

What is confusing is all of the "File and Printer Sharing" firewall settings are already enabled (see below).

What am I missing? Is there any other firewall rule to be enabled? Any ideas?

Thanks, AlefSin

(ps, I have only the Windows firewall, no other 3rd party virus protection or firewall programs).

enter image description here

Edit 1: I manually added a rule to the firewall to open TCP port 445. Now the shares are visible. So most probably what @Jacob mentioned is right: somehow the system does not recognize it is indeed connected to a "Private network", though at least parts of system think so:

enter image description here

  • Your solution should be its own answer.
    – Ramhound
    Commented Apr 6, 2016 at 16:42
  • 1
    Well, it is not a good solution though. Manually opening ports on the firewall is not something I would consider a good practice. At best it is temporary patch.
    – AlefSin
    Commented Apr 6, 2016 at 16:44
  • Except its the proper solution? That is obviously the port that the service, which is used by this functionality, uses. Opening ports used by services, services you want to use, isn't a security concern. If you are that worried, configure the rule, to only allow intranet traffic.
    – Ramhound
    Commented Apr 6, 2016 at 16:46
  • You have a point. I'll wait a bit and if nobody comes up with a way to understand the underlying cause, I'll add it as an answer for future reference.
    – AlefSin
    Commented Apr 6, 2016 at 16:48
  • 1

7 Answers 7


I manually added a rule to the firewall to open TCP port 445. This resolves the issue by allowing SMB2 and SMB3 over TCP. However, this solution is less than ideal since it does not answer the problem as to why the system's default firewall were not correctly setup by Windows.

  • 2
    Windows 10 takes VLANs into consideration. If you're on a different VLAN, shares won't automatically work.
    – Overmind
    Commented May 31, 2018 at 5:22
  • 1
    To clarify, it takes subnets into account so if your on a different subnet the default rules wont work as the only allow Local subnet. Often being on a different VLAN means being on a different subnet but to be clear it is the subnet that is the issue not the VLAN. Commented Mar 20, 2020 at 17:15

I had the same problem, and @JacobBoykin's answer made to look in the right direction. But it's not only about being on a private network for a "private network" firewall rule to apply. Note that a few columns further to the right, the scope of many (at least all private) rules is set to "Local subnet", such as here:

enter image description here

In my case, I was connecting to a server on (having subnet mask from a client computer (subnet mask; hence, the server's firewall did not recognize my request as coming from the same subnet, and did not apply the "private" rule. Similarly, since my current network was marked "private", the "public" rule was not applied. Regardless of how many rules I activated, no request came through.

The solution, in my (DHCP) case, was to edit rules to extend the scope; basically, I added "" to the scope of the private "File and Printer Sharing (SMB-In)", which opens port 445 to requests from that IP range. That was enough in my use case.

Alternatively, I guess I could have changed my IP configuration to have all computers on the same subnet.


I have the same problems, with folders on 2 Windows 10 computers, and I get it fixed.

  1. Firstly, go to Windows Defender Firewall on Local Computer (that has shared folders) then select Advanced settings Windows Defender Firewall with Advanced Security

  2. In Inbound Rules, double click on File and Printer Sharing (SMB-In) and in the tab Scope add your Remote Computer's IP address here. Click Apply File and Printer Sharing (SMB-In) Properties

  3. Problems resolved!


I had this same issue but when I looked at the advanced firewall rules I discovered that port 445 was already open. In my case it was because I was on a different VLAN. I fixed it like this:

  1. In the search box, type "firewall," then click on "Windows Firewall."
  2. Click on "Advanced Settings."
  3. Double-click on "Inbound Rules."
  4. Make sure the lines "File and Printer Sharing (NB-Session-In)" and "File and Printer Sharing (SMB-In)" are checked.
  5. Double-click on "File and Printer Sharing (NB-Session-In)" and select the tab that says "Scope" and change the remote address setting to "Any IP Address" then click "OK."
  6. Repeat on the line that reads "File and Printer Sharing (SMB-In)."
  7. I also wanted the server to ping on the net so I did the same with the setting for "File and Printer Sharing (Echo Request - ICMPv4-In).
  8. I also wanted name resolution, so I adjusted the scope for File and Printer Sharing (LLMNR-UDP-In) and (NB-Name-In).

There's a good explanation of these settings here.


I'm assuming your computers are not members of a domain, correct? I would double check your network location settings for your Ethernet connection and verify it is set to private before digging into Firewall settings.


  • 1
    Thanks a lot. Very interesting link. However, the connection is already set to "Private network" according to the network and sharing center.
    – AlefSin
    Commented Apr 6, 2016 at 16:29

Well, this worked for me... give it a go.

Go to Start, type Command Prompt (run as admin) in the search bar, at the command prompt enter the following commands. Its easiest to copy and paste from below, and press Enter after each paste:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi

sc.exe config mrxsmb20 start= disabled

Then reboot your Windows 10 machine;

This should do the trick.

  • 5
    What do these commands do? Where's a reference for them?
    – Eric J.
    Commented Jul 5, 2017 at 20:07

When sharing wasn't working for me on a very recent install, I gave up and reset firewall to defaults then re-enabled file sharing and let Windows get the settings right. I noticed as I did this one of the prompts was to "make the network I am connected to a private network" - this despite it already appearing to be labeled Private before. I suspect this Public/Private setting was somehow silently out-of-sync (as I bounced between two PCs signed in with a Microsoft account?) and was the cause all along.

  1. Windows Security -> Firewall & network protection -> Restore firewalls to default

    screenshot of Restore defaults screen

  2. Click "Restore defaults" button, answer "Yes" to the warning prompt (Note: you'll lose any custom firewall settings and will be prompted again with Windows Defender pop-ups as you [re-]open programs that use networking)

    screenshot of Restore Defaults Confirmation

  3. Visit Network in an Explorer window, click the "File sharing is turned off" banner then "Turn on network discovery and file sharing"

    screenshot of banner menu

  4. If you are prompted with "Do you want to turn on network discovery and file sharing for all public networks?" you probably want the first option "No, make the network that I am connected to a private network"

    screenshot of public network prompt

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .