0

On a computer running Windows 7 Embedded Standard (SP1), 64 bit, I am not able to view images in any chm files unless UAC is turned completely off.

All of the images are replaced with a small black and white box with an "X" in it.

Things I've tried:

Is there anything else I could try to narrow down the possible causes of this problem?

Are there any other security settings that can affect chm files?

Other related questions

  • What level is UAC set to when it causes problems? – Moab Apr 6 '16 at 18:10
  • I just ran through every UAC setting (with a reboot between each change), images only show if UAC is turned completely off. – jrh Apr 6 '16 at 18:25
  • 1
    Did you try to go one step back to IE10? See: How to downgrade from Internet Explorer 11 to Internet Explorer 10 – help-info.de Apr 6 '16 at 20:10
  • 1
    Use MJ’s Help Diagnostics to ensure (again) that all the help viewer components are properly installed and registered. Download from kb.helpwaregroup.com/ms-html-help/mj-s-diagnostics – help-info.de Apr 7 '16 at 19:12
  • @help-info.de Thanks. I recently noticed that another Windows Embedded 7 PC has no trouble with opening chm files, the only difference I could find between the PC that works, and the PC that doesn't work, is that the IE versions are slightly different. The working PC is running 11.0.9600.17689 and the non-working PC is running 11.0.9600.16521.... – jrh Apr 8 '16 at 13:55
1

In my case this was solved this by clearing the read-only attribute of the INetCache folder in Window's local Appdata folder. Source

0

I had the same problem but never touched UAC.

There are apparently different levels of authentication for the HTMLHelp MaxAllowedZone registry. Most articles I read tell you to set the MaxAllowedZone to '1' which means that local machine zone and intranet zone are allowed but '4' allows access for 'all' zones.

For more info, read this article: https://support.microsoft.com/en-us/kb/892675

This is how my registry looks (I wasn't sure it would work with the wild cards but it seems to work for me):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions]
"MaxAllowedZone"=dword:00000004

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions]
"UrlAllowList"="\\\\<network_path_root>;\\\\<network_path_root>\*;\\ies-inc.local;http://www.*;http://*;https://www.*;https://*;"

As an additional note, weirdly the "UrlAllowList" key was required to make this work on another PC but not my test one. It's probably not required at all but when I added it, it fixed the problem. The user may have not closed the original file or something like that. So just a consideration. I suggest try the least and test it, then add if needed. Once you confirm, you can deploy if needed. Good Luck!

P.S. Another method that worked was mapping the path to the network locally by using mklink /d (symbolic linking in Windows 7 or newer) but mapping a network drive letter (Z: for testing) did not work. Just food for thought and not really recommended. I also did not have to 'Unblock' any files and read probably all the same treads you did and no one had this solution which I thought was odd. Thanks.

  • I tested with URLAllowList, it didn't seem to have any effect, including after a reboot; MaxAllowedZone was already at 4. After that, just to try it I even added * and *.* temporarily to the end of URLAllowList. Thanks for the idea though. I'm not sure what you mean by the network symlink solution; this is on the D:\ of the computer (I've tried C:\ too), where D is a partition on the computer's hard disk; currently there is no network drive. Were you suggesting that the help file might work better if it resides on a network drive? – jrh May 26 '16 at 17:12
  • On windows from an elevated command prompt, use something like this (I use it all the time): mklink /d C:\<LocalPath> \\<UNC_Path\to\folder> – jacktrader May 29 '16 at 0:04
0

I've had this problem with an XP computer (not Seven) for years. I'm far from being a superuser so I managed to keep it this way for years! But recently I had a "stupid" idea. Went and see in IE advanced config... (This is not my default browser). The "show image" option was simply unchecked. I checked the box and guess what? It worked! I can see the image in CHM_help files again! Maybe it can help...

  • Thanks for the idea, but Internet Options -> Advanced -> Multimedia -> Show Pictures is checked. – jrh Jul 11 '16 at 14:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.