2

I bought a Lenovo G40 and it came with Windows 10 uses UEFI to boot. I am trying to install Linux Mint on an empty partition in order to dual boot. At first I had succeeded. However, after an update, it boots directly into Windows.

I tried reinstalling Linux Mint, but no luck (I get an error at the end of the installation saying that the installation won't boot).

I tried disabling Secure Boot and Fast Startup and then reinstalling Linux Mint. Same thing.

I tried using the Live CD to manually add a "boot" flag to the partition which has the Linux installation. Didn't work as well.

I tried using boot repair, but ended up with this error and no luck.

I read that to properly install Linux in this environment you have to boot the Live CD into EFI mode, and I think this is what I couldn't do. There is no UFI mode boot when I insert the Live CD, and there isn't an option to add this in the BIOS (at least I didn't find it). There following two shots of my BIOS show what appears when I have Legacy mode on and off (both have the same result).

enter image description here enter image description here

Any ideas? Any way that I can boot both in Linux and Windows I'm happy (even if I have to make the dual boot through Windows Boot loader).

Cheers.

  • "However, after an update, it boots directly into Windows." - You need use GRUB2 to detect linux installation, just like you would, if you installed Windows after Linux exact same principle. – Ramhound Apr 6 '16 at 20:47
  • @Ramhound pardon my ignorance (I'm kind of new to grub and boot still), but I thought that's what I was trying to do with BootRepair and reinstallation of Mint. Can you maybe be more specific (maybe even an answer)? Thanks – TomCho Apr 6 '16 at 21:02
  • I am not sure the reason you are disabling Secure Boot, Linux Mint, should fully support it. "there is no UFI mode boot when I insert the Live CD, and there isn't an option to add this in the BIOS (at least I didn't find it)." MBR or GPT partitions, I suspect you might think you have Windows 10 installed in EFI mode but your mistaken. Of course by "EFI Mode" it simply means NOT enabling legacy/compatability mode. – Ramhound Apr 6 '16 at 21:06
  • @Ramhound I disabled Secure Boot because all the tutorial to install Mint with EFI had that step. I added two pics of my BIOS that might help. That's the main reason I think I have Windows installed in EFI. What do you think? – TomCho Apr 6 '16 at 21:23
  • The reason your Live installation isn't being displayed is because its missing the required drivers. Once the required drivers exist on the image it should be displayed. – Ramhound Apr 6 '16 at 21:31
0

I had the same issue on an Acer Aspire V3 with a similar looking BIOS, InsydeH2O revision 5.0. This solution worked for me.

  • Well, I followed step 1, which is to input an Admin Password, but then I couldn't find the Select an UEFI file as trusted for executing anywhere. Some ptions then appeared under Legacy Mode, which the Windows Loader, DVDRAM and Network Boot. But I don't know how that helps. I can post a picture if you'd like. – TomCho Apr 6 '16 at 22:45
  • The boot mode must be UEFI with secure mode enabled. You should not see anything with legacy mode. On my laptop the secure UEFI mode is active by default; you can load the default settings under Exit -> Load Setup Defaults. – Stéphane Tréboux Apr 6 '16 at 23:00
  • But under UEFI the only option that appears is the Windows Loader. Setting an admin password didn't change that at all. – TomCho Apr 7 '16 at 0:37
  • Ok then my solution probably doesn't work with your laptop, sorry for that. – Stéphane Tréboux Apr 7 '16 at 5:04
0

You could try to copy shimx64.efi (or whatever the boot file is on your distribution) to /EFI/Boot/bootx64.efi on your EFI partition. This is the default boot option on many UEFI BIOSes. This will not work alongside Windows though since /EFI/Boot/bootx64.efi is the default boot file for Windows.

  • Thank you, but I really both to be activated. – TomCho Apr 9 '16 at 21:23
  • I think there should be a way to boot Windows from grub once you have your UEFI loading grub. But I am not sure how it works (I stopped using Windows years ago). – Stéphane Tréboux Apr 10 '16 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.