2

Background
So I've been looking for this to work for some time now. I'm sure there must be a solution as I can't believe that no one in China or Japan have ever tried exporting contacts. What I've found so far is this Microsoft forum discussion that doesn't come to any conclusion, as well as this SuperUser question that doesn't give a satisfactory answer as it only says it works within Outlook.

Issue
So, my issue here is that I have a lot of Outlook contacts that I would like to import into SalesForce. SalesForce can take any CSV file and import it as contacts. When I export my Outlook contacts all the Japanese characters become question marks. If I import this into SalesForce the question marks remain, indicating that it's not that my editor can't show the characters, it's that the characters are really messed up (question marks in Excel, Wordpad, Notepad, Notepad++).

Troubleshooting so far
If I manually change some of the question marks to the proper Japanese characters and import this into Outlook it works - indicating that SalesForce can use Unicode characters. The exported CSV file is saved as ANSI encoding, so the issue is how Outlook encodes the export.

Question
How can I force Outlook to export the contacts as CSV with Unicode encoding? Is this an Outlook issue or is it a system setting where CSV files default back to ANSI? How could I go about changing this?

  • I'm pretty sure outlook file is ascii – Raystafarian Apr 7 '16 at 9:49
  • When opening it in Notepad it looks ilke it is ANSI but it seems that you are correct here. Regardless of it being ANSI or ASCII by default, I would really like to change it to Unicode. – MagneTism Apr 7 '16 at 11:47
  • I meant that not in that you were incorrect, but in I don't think it's possible to change the encoding through outlook. – Raystafarian Apr 7 '16 at 12:59
  • No worries, I was incorrect :) It looks like you are correct in that it cannot be changed. What I did find was the following article explaining how to change the account to a Unicode account: support.office.com/en-us/article/… However, I checked with our IT manager and he showed me that it actually is set to Unicode so something else must be at play here, maybe some local setting on my computer. – MagneTism Apr 7 '16 at 13:04
1

I was struggling the same issue with Hebrew and finally came out with this solution:
* In (Office) Outlook add you Outlook.com account. Create new one if not exist.
* Copy all your Exchange contacts to Outlook.com contacts.
* Open your Outlook.com in a web browser and open the People app.
* make sure all your copied contacts are there and choose Export all contacts.
* Export to csv file and save it on your hard disc.
* open the saved csv file with notepad and then Save As and make sure it's UTF-8 format.

That's it - now your csv file is using the right international characters.

-2

the best confirmed way is to use an android mobile. I hope you have :)

Note about using Outlook.com:

until Microsoft outlook 2016, there is no option to export with unicode option. Outlook.com allows you to export with unicode, but unfortunately, even you connected your outlook to outlook.com, contacts created in outlook are not synced back to outlook.com, which means you cannot export your local contacts, but only the contacts you created directly on outlook.com

How to use android phone:

  1. add your email account having the contacts, and make sure you select to sync contacts as well. this is the default settings when you add an account.
  2. open contacts in android, and make sure you select to show only contacts from that new account (this is available in contact settings).
  3. from the contact settings on the phone, you will have an option to export contacts to the phone storage, just do it.
  4. from the settings, you have also an option to import contacts. however, when you select to import, it will ask you to which account you need to import. here select google account. if it asks, select the file you already export. however most of the phones will not ask you for a specific file, and it will find immediately the exported file.
  5. wait couples of minutes to allow the sync process to finish, or you can force it to start from the account settings in android.
  6. Once contacts are in google, use a PC to login to contacts.google.com and export to csv. the exported file will have Unicode support.
  7. Use normal import into anywhere, depending on the desired system.
  • 3
    OP asks about exporting contacts and IMPORTING THEM TO SALESFORCE. Your solutions stops with contacts in the phone, how you can export them to Salesforce? – Máté Juhász May 30 '17 at 6:56
  • his problem is not in importing, but in exporting from outlook with Unicode support. my solution is to allow him, using a Mobile phone, to transfer his contact to google with Unicode. once contacts are in google, he can make export with Unicode, and then import it anywhere. – omarmallat May 31 '17 at 7:56
  • even in his description to his issue, he summarize his question by asking how to export with Unicode, and not how to import, because he explained how he imported to SalesForce a bad file. I did not see how you find that I'm not answering his question. – omarmallat May 31 '17 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.