0

I see like 15-20 chrome.exe processes in task manager and yes I know chrome uses several processes to separate workload. But the worst part is, I din't even oppened Chrome and yet I see those 20 processes, and in the last few weeks or so, one or two of those processes run on at least 30-50% CPU power which makes my cooler work harder. I even think chrome is doing something with my Internet connection as I cannot play multiplayer MOBA game without unbearable lags.

As if I have some virus, but not sure, I scanned with Spybot S&D and it found only regular things it finds each time I scan.

Should I remove Chrome or what should I do, any suggestions?

Note: There is not Service in Windows Services Management. And also In Chrome process list when I open in Tools-> Task Manager I see only few processes.

By the way it is Windows 7

  • A processor under load cannot cause latency (or lag) – Ramhound Apr 7 '16 at 22:14
3

Open Chrome and disable 'background running' in the settings:

  1. Go to chrome://settings/ (paste this in the omnibar)
  2. Scroll all the way down, open 'Show Advanced Settings...'
  3. Scroll all the way down, next to last is System, uncheck 'Continue running background apps when Google Chrome is closed'.

If you have a runaway process from earlier, it will be gone after reboot. No more Chrome processes should show up then.

Note that nothing keeps a virus from naming itself Chrome.exe - that is an option to explore if this all fails.

  • Yes that option was off when i oppened advanced settings, but still chrome.exe is processing something and I see "million" chrome.exe processes. Will remove Crhome and see what happens. – Vlad Apr 8 '16 at 8:05
  • But guess what, I cannot remove Chrome because of those "million" processes in background hehe – Vlad Apr 8 '16 at 8:06
  • Managed to close all those chrome.exe processes and uninstalled it. Restart, and voilla, no chrome.exe running in background. There is ChromeUpdate.exe but it does nothing. – Vlad Apr 8 '16 at 8:24
  • ChromeUpdate checks once a week for an update. – Aganju Apr 8 '16 at 10:28
5

You probably have some Chrome extensions that are allowed to run when Chrome isn't running. To turn this feature off:

  1. Right-click Chrome's icon in the notification area, next to the clock.
  2. Click Let Google Chrome run in the background to disable it.
  3. Right-click the icon again and choose Exit.
  • I don't see that icon anymore :) – Vlad Apr 7 '16 at 22:09
  • Then it worked, I guess. Chrome processes should be gone too. – gronostaj Apr 7 '16 at 22:10
  • No it doesn't work. Still one million chrome.exe processes. I dont even use Chrome and yet it is processing something. – Vlad Apr 7 '16 at 22:11
  • I never had such an icon. Which version are you running under which OS? – Aganju Apr 7 '16 at 23:29
  • 1
    @Aganju Chrome 49 under Windows 10. The icon has been there since Chrome 30 or so. It doesn't appear if you don't have extensions that require running in the background. Install Gmail Offline, for example, and it will appear. – gronostaj Apr 8 '16 at 6:38
0

Well this surely cannot be the right answer but I had to remove Chrome in order to release some of the resources it was using for no reason, without me launching Chrome at all.

I removed it and then installed it again, and again it was making 20 processes, one or two were using like 30%-50% of processor power and a playing MOBA game was lagging. Removing it fixed this issue. Either my Windows needs format or Chrome has some bug :)))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.