0

I am trying to use a Apacer portable USB HDD, which is USB 3.0, with Windows XP, and have some trouble on this machine.

First, when I connect the USB HDD directly to XP, it gets recognized as a Portable HDD, and drivers start installing; however, at the same time, I can hear clicks from the HDD, apparently from it getting too low power for the disk to spin up - and the driver install process here never finishes completely (as I interrupt it after 5 mins or so, as I'm thinking, all these spin-clicks cannot possibly be good).

Suspecting this is a power issue, I got a Konig USB hub with external power supply. The USB 2.0 hub by itself gets recognized immediately by XP as "Generic USB hub", so all is good there. But as soon as I plug something into the hub, Windows XP recognizes an "unknown device", and that is it - this happened both for the portable USB 3 HDD, and for a USB thumbdrive which is USB 2. I used USBDeview (http://www.nirsoft.net/utils/usb_devices_view.html), and I can see that anything that has been plugged into this hub, ends up with Vendor/Product ID of 0000 ?! So no surprise that the correct drivers can not be loaded...

Btw, the exact same machine has dual boot with Ubuntu 14, and in Ubuntu, when I plug the portable USB3 hdd, again I hear the spin up clicks - but when I connect it through the powered USB hub, all is fine and the drive automounts. So I guess this is not a hardware problem with the hub or the portable USB3 hdd.

So, the question is - why would XP receive product/vendor ID of 0000 for any device plugged into the USB hub (which is itself correctly handled by XP. and has extern power supply so power shouldn't be an issue); and is there a fix possible, so the correct devices are detected by XP when they are plugged in the USB hub?

  • 1
    It does sound like your port wasn't providing adequate power, and since Ubuntu can enumerate the device properly on the same wires, my first though is look into updated USB root hub drivers, possibly via intel (or other chipset mfg) – Yorik Apr 8 '16 at 15:16
  • Many thanks, @Yorik - will try to do so... Cheers! – sdaau Apr 8 '16 at 15:18
  • 1
    also, msinfo has a component tab that may list an error code under "problem devices" support.microsoft.com/en-us/kb/314464 – Yorik Apr 8 '16 at 15:19
  • 1
    And don't forget to check for potential HDD size limitations for WinXP – Yorik Apr 8 '16 at 15:21
0

Ok, got this solved, so I'll post as an answer - but it was a bit trial and error, so I won't be accepting this answer, and I hope eventually someone can post a more erudite explanation of this problem.

But, here it is: first of all, I forgot to mention that the XP/Ubuntu PC is a desktop one, and as most desktops, it has (two) USB connectors on front panel, and (four) USB connectors on back panel. The tests I did - and the problem described in the OP, were done only with the front panel USB connectors.

I have heard that typically in this desktop configuration, the front panel connectors may have been designed to deliver less current than the back panel ones. So I thought, in the end, what the heck, I may as well try to connect the USB hub to a back panel USB connector. And whaddayaknow, as soon as I did that, and connected the USB portable HDD to the USB hub - Windows XP recognized the attached drive properly, mounted it, and it works without all those spinning click noises! Nice!

Now, I'm really not sure why would this make a difference - maybe the front panel USB connectors have malfunctioned slightly (as they still seem to work fine when other low-power devices are connected to them, such as USB mice). Or, maybe the USB hub itself drains power from the PC USB connection to power its controller, and it uses the extern power solely to power devices attached to it?! Cannot really tell - but I'm happy it works now...

| improve this answer | |
  • sounds like it was indeed a driver issue. As both those sets of ports, are handled by two different USB Hubs, which means likely two different USB chipset drivers. – Ramhound Apr 8 '16 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.