1

I’m trying to install Google chrome on the following version of 64-bit Linux …

[davea@mydevbox mydir]$ uname -a
Linux mydevbox.mydomain.com 1.3.8-18.52.amzn1.x86_64 #1 SMP Wed Mar 16 17:15:34 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

After downloading the rpm package and attempting to install, I get the below errors …

[davea@mydevbox ~]$ sudo rpm -ivh google-chrome-stable_current_x86_64.rpm 
[sudo] password for davea: 
warning: google-chrome-stable_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
error: Failed dependencies:
    xdg-utils is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libatk-1.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libgconf-2.so.4()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libgdk_pixbuf-2.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libgdk-x11-2.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libgtk-x11-2.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libpango-1.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libpangocairo-1.0.so.0()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libXcomposite.so.1()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libXcursor.so.1()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64
    libXrandr.so.2()(64bit) is needed by google-chrome-stable-49.0.2623.112-1.x86_64

Another link said I need to have the “lsb” and “libXScrnSaver” installed, which I did through yum. Is there any way to install Google chrome and have all the dependencies automatically installed for you?

Edit: I tried your suggestion, but am getting a bunch of errors about not being able to find dependencies …

[davea@mydevbox ~]$ sudo yum --nogpgcheck localinstall google-chrome-stable_current_x86_64.rpm
[sudo] password for davea: 
Loaded plugins: fastestmirror, priorities, update-motd, upgrade-helper
Examining google-chrome-stable_current_x86_64.rpm: google-chrome-stable-49.0.2623.112-1.x86_64
Marking google-chrome-stable_current_x86_64.rpm to be installed
Resolving Dependencies
amzn-main/latest                                                                                                                                                                     |  2.1 kB     00:00     
amzn-updates/latest                                                                                                                                                                  |  2.3 kB     00:00     
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:49.0.2623.112-1 will be installed
--> Processing Dependency: xdg-utils for package: google-chrome-stable-49.0.2623.112-1.x86_64
Loading mirror speeds from cached hostfile
 * amzn-main: packages.us-east-1.amazonaws.com
 * amzn-updates: packages.us-east-1.amazonaws.com
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgconf-2.so.4()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:49.0.2623.112-1 will be installed
--> Processing Dependency: xdg-utils for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgconf-2.so.4()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
---> Package libXcomposite.x86_64 0:0.4.3-4.6.amzn1 will be installed
---> Package libXcursor.x86_64 0:1.1.14-2.1.9.amzn1 will be installed
---> Package libXrandr.x86_64 0:1.4.1-2.1.8.amzn1 will be installed
---> Package pango.x86_64 0:1.28.1-10.11.amzn1 will be installed
--> Processing Dependency: libthai >= 0.1.9 for package: pango-1.28.1-10.11.amzn1.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.28.1-10.11.amzn1.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.28.1-10.11.amzn1.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.28.1-10.11.amzn1.x86_64
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:49.0.2623.112-1 will be installed
--> Processing Dependency: xdg-utils for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgconf-2.so.4()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: google-chrome-stable-49.0.2623.112-1.x86_64
---> Package libXft.x86_64 0:2.3.1-2.7.amzn1 will be installed
---> Package libthai.x86_64 0:0.1.12-3.5.amzn1 will be installed
--> Finished Dependency Resolution
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: xdg-utils
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: libgdk-x11-2.0.so.0()(64bit)
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: libatk-1.0.so.0()(64bit)
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: libgconf-2.so.4()(64bit)
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: libgtk-x11-2.0.so.0()(64bit)
Error: Package: google-chrome-stable-49.0.2623.112-1.x86_64 (/google-chrome-stable_current_x86_64)
           Requires: libgdk_pixbuf-2.0.so.0()(64bit)
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
2000:jdk-1.6.0_45-fcs.x86_64 is a duplicate with 2000:jdk-1.6.0_35-fcs.x86_64
2000:jdk-1.6.0_65-fcs.x86_64 is a duplicate with 2000:jdk-1.6.0_45-fcs.x86_64
  • Doesn't yum do it? It should with sudo yum --nogpgcheck localinstall packagename.arch.rpm but replace "packagename.arch.rpm" with your rpm file – acejavelin Apr 8 '16 at 19:44
  • Google-chrome is a special beast evidently . I get the above errors complaining about missing libraries when I try your suggestion involving yum. – Dave Apr 8 '16 at 20:54
0

You obviously use Amazon Linux. This is derivate of CentOS. But with some changes. So I'm not sure if your goal is even possible. It is better to use CentOS. But even then - some version of Chrome does not support CentOS, then Google add the support back. IIRC this support/not supported flip happen several times. So you will be save with using Chrome on Fedora. There is even repository with Chromium (free version of Chrome) for Fedora.

  • Hi, It is not an option to switch teh version of Linux I use. My question stands with the given constraints. – Dave Apr 11 '16 at 13:59
0

You can follow the instructions here for 64-bit, using skip-broken to avoid problems on install:

https://www.linkedin.com/pulse/using-yum-install-google-chrome-aws-linux-ami-konstantinos-demiris

Beware of bad hyphens in those instructions! Copy and paste to a text editor, then fix all the hyphens before running those commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.