10

I run VMWare player 2.5.0-118166 from Ubuntu 8.10 using Gnome 2.24.1.

  • I can find no menu options to send the combination to the welcome screen.
  • Ctrl+Alt is being picked up by VMWare Player and releases input, so Ctrl+Alt+Del/Ctrl+Alt+Ins can't be typed in directly.
  • Ctrl+Alt+Space should suppress VMWare Player from picking up the next keyboard input, but following this with Ctrl+Alt+Del or Ctrl+Alt+Ins does not seem to work.

So I'm stuck, not able to log in to my Windows image.. How can I send a Ctrl+Alt+Del to Windows within VMWare Player?

1

16 Answers 16

21

Ctrl+Alt+Insert. In my experience with VMware products (Workstation and Server; I must say I have not tried Player, but I can't see any reason why it differs), Ctrl+Alt only has special effects if you press and release them on their own, without an accompanying key.

Oh yes, I remember. It only works when the input is grabbed, or not (I can't remember which). Try grabbing/ungrabbing the input and doing that keystroke again.


Edit (gleaned from other answers; thanks!): If Ctrl+Alt+Ins doesn't work, try:

  • Crtl+Alt+PrtSc
  • Ctrl+Alt+End

VMware has some really funky keyboard mapping issues (at least on some versions, and at least on some platforms).

4
  • 1
    Don't work for me. Maybe Gnome eats the key combination?
    – Alf
    Nov 4 '08 at 9:54
  • I can't remember if it requires input to be grabbed first, or ungrabbed. I don't have VMware working on my computer at the moment, but try both and see. Nov 4 '08 at 9:56
  • Both tried. Neither works.
    – Alf
    Nov 4 '08 at 9:57
  • Soooo odd. Even the VMware person thinks C-A-I should work: communities.vmware.com/thread/23712 Nov 4 '08 at 10:04
7

After some more googling I finally found the solution.
It seems that the key combination is Ctrl+Alt+Print_Screen.

It might be that Ctrl+Alt+Insert works on other platforms.

2
  • Wow! That's bizarre! I'll favourite this post so I can refer people to it. Nov 4 '08 at 10:05
  • Works for me as well.
    – HappyCoder
    Sep 25 '09 at 9:27
2

Definitely works for VM Player: Ctrl+Alt+the period on the number pad.
If you have a laptop without seperate number pad (as I do) then press Ctrl+Alt+Fn then >

The host will take the focus as though it did not work, but after you click cancel you go back to the VNC session and it now displays the login prompt.

1
  • Great! This works for me!!!!!!!!!!!!!!!!!!!!!!!!!
    – tmow
    Feb 5 '13 at 16:26
2

If you have trouble with Ctrl+Alt+Insert, try Ctrl+Alt+End.

1
  • Worked for me! Note that I was remote desktoped into a computer which was then running vmware player. Ctrl-Alt-End sent the ctrl-alt-del to the remote desktop, which caused both it and the VM to respond. Thanks! Nov 17 '09 at 18:30
2

VMware has the menu bar at the top. Select Virtual Machine, then in the drop down you will see the command - send Ctrl-Alt-Del

1
  • Doesn't work for fullscreen mode.
    – Pacerier
    Feb 28 '15 at 15:21
1

I'm RDPed into a VMWare Essentials host server and was having issues with Ctrl+Alt+Insert because the cursor was released from the console.

If you're having this issue just click/focus back in the console and hit Ctrl+Alt+Insertagain.

If that doesn't work try Ctrl + Alt + End and you should be able to get to the logon screen. This happened to me on a different VM.

0

If you are on a Macbook Pro, there is no Ins key or Print Screen. Instead: Fn+Control+Alt+Delete

Does the trick to open up the login screen.

0

Mind notebooks/keyboards with the Fn function for keys. Push it together with Ctrl+Alt+PR_SCREEN.

0

I usually access my VMs via UltraVNC, which has a CAD (Control + Alt + Delete) button in its toolbar.

One mouse click sends the three-finger salute.

0

Ctrl+Alt+Print-Screen works perfectly in Ubuntu 9.04.

0

On Ubuntu (x64, 8.10) and VMWare Player 2.5: Ctrl+Alt+Del can be emulated as Jon and brian already answered:

  1. Ctrl+Alt+PrtScr
  2. Ctrl+Alt+NumDel

Don't release Ctrl+Alt keys before pressing third one, or You will lose keyboard focus.

0

I'm running an XP VM in VMWare Player 2.5.1 on Vista 64bit via Remote Desktop.

The only one that worked for me was Ctrl+Alt+End.
It took me to the shutdown screen for Vista but when I cancelled that the VM was at the login dialog. I pressed Ctrl+G first, not sure if that was vital or not.

0

Ctrl+Alt+NumDel (the one that also acts as a period on the numpad) also works perfectly.

0

USE EASE OF ACCESS ON THE VM SCREEN TO TURN ON THE OSK (On Screen Keyboard).

OMG finally figured it out - nothing above worked.....Windows 2012 R2 server copied a VM from site1 to site 2....NIC IP different so vSphere console will not open.

Used IE or Chrome to get to the console...but no option to press CTRL+ALT+DEL.

On the VM screen ==> LOWER LEFT corner ==> EASE OF ACCESS > on screen keyboard ==> CTRL+ALT+DEL.

Get that...you're using the OSK in the IE/Chrome window, NOT the host VM you're logged into, like you would IF you were using RDC.

0

Came here looking for keyboard shortcut for sending Ctrl+Alt+Del for VMware Workstation 15 on Windows 10. Ctrl+Alt+Insert worked for me.

-1

The "Host" key is whatever is assigned in File / Preferences / Input / "Host Key Combination". The default for Oracle VM VirtualBox (running Win7 in my case), is the "Right Ctrl" key. So, the key sequence to unlock the Ctrl+Alt+Del screen would be RightCtrl+Del.

1
  • 1
    The question is about VMWare... Mar 13 '19 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy