I am using a windows "standard" ISO file: Win10_1511_1_English_x64.iso and I have verified its md5 matches the expected. The iso is mountable in OS X as a "UDF" format.

I then copy it "straight" to my USB drive, like:

sudo dd if=Win10_1511_1_English_x64.iso of=/dev/rdisk1 bs=1m

then plug it into my dell optiplex 780 (a little old, I know), enable booting from USB device in the BIOS, and choose it, and all I get is:

No boot device available - strike F1 to retry boot ... no boot sector on USB device

What am I doing wrong?

The created USB is readable in OS X, but in other windows boxes, it just says "You need to format the disk in Drive E: before you can use it." So it doesn't boot, nor can windows read it...

Update: I ran the OS X "Boot Camp Assistant" (check the box "Create a Windows 7 or later version install disk" and gave it the same ISO file), then it magically boot fine (appears to be formatted FAT32). Maybe it's some special Dell limitation they can only boot on USB if it's FAT32? Why would it not boot from straight UDF?


3 Answers 3


I cannot seem to find an official source for it, but it appears that "UDF" if copied verbatim, cannot be booted from USB. And many ISO files are UDF formatted.

Appears that for "cd rom drives" being able to boot from them is accomplished by their conforming to the El Torito standard. However for "normal" disk to boot, the "MBR" has to be set in it (which is apparently different bits than the El Torito bits). And apparently you can set one or the other, or both.

So basically, if it's an ISO that's "just" El Torito, you "have" to use a tool (or carefully do the formatting, partition marking, and file copying manually), that will give you a MBR formatted, bootable USB. Copying raw ISO bits is not enough.

A "few" ISO's may not need any special tool: (note the mention of "isohybrid," whose documentation mentions that normal ISO's (UDF formatted) are only bootable from CD drives unless you add an extra master boot record [i.e. outside of UDF spec], apparently many main-line linux distro ISO's are made this special way, but I know from experience windows install ISO's of at least windows 10 are not).

For the ones that do need it, apparently you should avoid raw disk copies from ISO to USB (ex: the dd command on unix*'s). Or you'll run into the problem I did.

In my experience, typically you'll be converting from a UDF ISO to a FAT32 USB device. (The former is El torito, the latter MBR, for their "boot system").

How do I place a bootable ISO on a USB drive? (lists lots of utilities that do this "for you")

See also https://apple.stackexchange.com/a/234290/25085 for OS X related options.


https://blogs.msdn.microsoft.com/matt-harrington/2012/03/27/how-to-create-a-bootable-usb-drive-from-an-iso-image-for-uefi-systems/ (mentions that it needs to be FAT32, and have files copied from the ISO).

update: No amount of unetbootin seemed to work for me, bootcamp neither on newer iso's. I'm guessing I was installing to an older box which couldn't read newere boot schemes. Using rufus on windows "MBR" and "NTFS" (fat32 might have worked as well, but got some complaints of "install.win" being too big) and it worked for a windows 10 iso.

  • 1
    Every windows bootable usb installer I have made since Vista has been fat32, not sure it is a Dell issue though.
    – Moab
    Apr 8, 2016 at 22:25
  • 3
    The answer is quite right except all the bits about UDF. The issue doesn't really have anything to do with ISO9660 vs UDF (and neither is ISO files are almost all UDF formatted true). It's about whether the ISO is made purely as per El Torito or "hybridly" including an MBR.
    – Tom Yan
    Apr 9, 2016 at 9:14
  • @TomYan ahh that explains it, thanks! I tried to update it.
    – rogerdpack
    Apr 10, 2016 at 1:55
  • I was able to create a bootable Windows 10 usb drive from Ubuntu linux using a tool called 'wimsplit'. A full tutorial is shown here: gist.github.com/dragon788/26921410d8de054366188c5c5435ae01 Jun 22, 2020 at 22:31
  • bootiso , seriously - just made everything for me, and it is also suggested in link above
    – silpol
    Sep 27, 2021 at 19:01

lose 1 in rdisk1. you have to copy the iso to the drive instead of partition for it to work.

example: sudo dd if=my.iso of=/dev/sda bs=8M


From the comments, woeusb seems to be "a script" so similar to the gist, they all wrap the complexity and use wimsplit if going to FAT32 and files are too big I think :) https://askubuntu.com/a/1098185/20972 so another option that's linux y

Not the answer you're looking for? Browse other questions tagged or ask your own question.