0

My company has an internal webapp to track some of our clients' information. This webapp uses Silverlight, but whenever I try to log in to it, I get the following error:

Silverlight IsolatedStorage_Operation error popup

[IsolatedStorage_Operation]
Arguments:
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem.
See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.41212.00&File=mscorlib.dll&Key=IsolatedStorage_Operation

The link in the message provides the explanation for the error and offers this solution:

To see these descriptive error messages on your local machine and obtain other debugging resources, please install the latest version of Silverlight for Developers on your Windows or Mac computer.

I have tried installing Silverlight for Developers (version 3) as provided in the link (for Windows). I had to manually uninstall (via appwiz.cpl) my current version in order to do so.

After installing SfD, trying to open the app fails because I don't have the most recent version of Silverlight:

Silverlight version is too old.

But clicking Install Now takes me back to the first error!

I have also tried to find SfD on Microsoft's Download Center, to no avail. Perhaps I am looking in the wrong place?

How can I get the right (latest) version of Silverlight for Developers?

closed as off-topic by DavidPostill Apr 8 '17 at 12:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – DavidPostill
If this question can be reworded to fit the rules in the help center, please edit the question.

  • looks like your webapp has a problem. have you tried it from another source? – G Koe Apr 9 '16 at 6:41
  • Other people have been able to use it just fine, so it seems to be local to my system. My job doesn't depend on accessing it (though it would be helpful), but theirs does. – Jed Schaaf Apr 9 '16 at 6:43
  • 1
    Have you contacted your company's tech support? Also do you access through a web browser? If so, use IE. – Raystafarian Apr 9 '16 at 8:48
  • 1
    Issues specific to corporate IT support and networks are off topic, see On-Topic. Please talk to your IT department. – DavidPostill Apr 9 '16 at 10:29
0

After going around with multiple departments at my company and trying multiple possible solutions, I finally found the issue:

Internet Explorer's InPrivate browsing mode is incompatible with Silverlight's Application Storage.

After disabling InPrivate mode, the app worked correctly. My guess here is that InPrivate prevents Silverlight from saving anything to its app storage.

  • You should mark this as the solution by ticking your answer :) – Kinnectus Nov 17 '16 at 18:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.