3

I have a Toshiba Satellite L50-B-2G9, which takes hours to boot.

Initially I had Windows 8.1 and Ubuntu 15.10 installed side-by-side and switched between them regularly. I noticed it took longer and longer to boot. To rule out software I formatted the harddisk and did a clean install of Ubuntu 15.10.

At this point turning on the computer yields a lit up power button, a WiFi enabled indicator light (which can be turned off by the F12 key), a black (turned off) screen, a spinning fan and a processor which appears to be doing something as it is producing heat. I don't know if the hard disk does something because it's a solid state. After many hours, for the last couple of times I left it overnight, the laptop will usually boot and the OS will load. Once started all seems to be fine until the next reboot.

I'm guessing there is something wrong with the UEFI but I don't know how to troubleshoot this issue.

To rule out the disk completely I've also tried a live Ubuntu 15.10 but the results are the same.

As I mentioned the screen is completely off and it takes hours until the Toshiba startup screen shows. Once it shows, the computer works normally. To clarify the image below shows the screen I am talking about.

enter image description here

As requested, below is the SMART data. The disk seems to be fine.

SMART data

  • What does the SMART data say about the health of the hard drive? – Moab Apr 9 '16 at 20:22
  • @Moab, I've uploaded a screenshot of the SMART data. When you commented it was already trying to boot for 2-3 hours and I've checked the SMART data as soon as the laptop started. it took 7-9 hours between turning on and actually starting. – SilentRevolution Apr 10 '16 at 1:49
  • Have you tried booting a live Linux USB or CD, to rule our the drive completely? – Alexander O'Mara Apr 10 '16 at 8:06
  • I have @AlexanderO'Mara but to no avail, same issue. – SilentRevolution Apr 10 '16 at 9:06
  • I believe that is the windows side of things, because you could use Ubuntu's dual boot menu, which I think is called the GRUB menu. Because it brings up Toshiba I think that's windows booting first. Can you upload a screenshot of your dual boot screen please? – JCTechie Apr 15 '16 at 21:51
0

It's either hardware or software. Below are some tests -- if any fail (except #2 below) after two minutes, wait no longer, reboot, and proceed to the next. (i.e. please don't wait 2-3 hours each time.)

  1. Remove the SSD, try rebooting again with a known working Linux USB or CD. If that boots quickly, the problem is the SSD.

  2. If (with no SSD) it still boots slowly, it might conceivably be a BIOS firmware bug, and perhaps there are updates that fix it. This is doubtful though and I've never heard of a firmware bug that caused hours-long boot-ups. Unfortunately, you may have to wait 2-3 hours just to see the BIOS, and getting into setup probably means hitting the F10 key or something right after the moment it comes to life, which could be a problem.

  3. Hardware tests.

    • Power supply: try plugged in, unplugged, and no battery but plugged in.
    • RAM: try a different stick, or if there are no spares laying about, try with none, or if there's more than one stick, one stick at a time.

There's other possibilities, but the above are easiest to check.

The OP doesn't mention if the two hour boot applies to a soft boot, (i.e. a reboot), as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.