1

So a while ago I've created a bootable USB stick with Kali Linux (with encrypted persistence) on it. Since I wanted to use it with a mouse on my Surface Book 3 I have bought a USB hub (Kali Linux has issues with the trackpad on the typecover). Everything worked fine until recently I started having problems with this USB hub in combination with the Surface:

  • The Surface doesn't recognize the USB Stick if it is pluged into the hub
  • Plugging the stick directly into the Surface however causes no problems
  • Booting from the stick only works if it is plugged into the Surface directly, without the hub

I tried booting from this stick while it was on the hub on another windows 8.1 machine and it caused no problems whatsoever.

I also tried reinstalling drivers in the Device-Manager and also disabled "allow windows to disable this device to save power" (before i disabled this, windows sometimes froze when the hub was connected.

EDIT: Yes, it should have enough power, it has worked before. A USB stick also doesn't need a ton of current.

  • Not enough power in your hub? Try a powered hub. – DavidPostill Apr 9 '16 at 22:34
  • @DavidPostill worked fine a while ago, without being powered aditionally – technical_difficulty Apr 9 '16 at 22:38
  • Then it's a faulty hub. Buy a new one. – DavidPostill Apr 9 '16 at 22:39
  • @DavidPostill It isn't, I tried it on various other computers which had no problems with it – technical_difficulty Apr 9 '16 at 22:41
0

After almost a week of trying I have found that the following helped:

  • I uninstalled the driver of the USB hub
  • Fully shutdown windows
  • Connected the hub and let the drivers automatically install again

Then I have connected the stick slowly with the hub so that only its main four pins (The pins used to ensure backwards compatibility with USB 2.0) were connected to it. Windows then has recognized the USB Stick and after it was recognized i could fully put it into the port. When booting I also haven't completely put the stick in the port, but after the os was fully loaded I could enitrely insert it without any troubles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.