I noticed that while HTML5 videos work fine, flash videos do not load. I have researched this and have tried numerous things to no avail.

1) I've tried uninstalling/reinstalling Chrome (deleting everything, even the Google folder in localappdata).

2) I've tried disabling/enabling Adobe Flash Player from chrome://plugins/

3) I've tried resetting all settings from chrome://settings/

4) I've tried disabling all extensions.

When I uninstall and then reinstall Chrome, however, the problem goes away. I am able to view flash videos. But when I sign into Chrome and have all of my bookmarks, settings, and extensions synced automatically, the problem comes back.

Below is the list of extensions I use:

Empty New Tab Page

Google Docs Offline

History Eraser App

Mailto: for Gmail™

Reddit Enhancement Suite

uBlock Origin

What could be the issue?

  • Can you try uninstalling all your extensions? That is the only part of chrome that is synced and cancreate an issue like this. Apr 10, 2016 at 8:31
  • 1
    @Private I uninstalled all extensions, but nothing changed. So with all the extensions uninstalled, I went ahead and uninstalled/reinstalled Chrome. The flash videos played fine now. So I tried installing an extension one by one starting with uBlock Origin. Immediately, the flash videos stopped working. Uninstalling that extension at that point did nothing as well.
    – John
    Apr 13, 2016 at 5:48
  • Good job, you got the solution. Apr 13, 2016 at 12:34

1 Answer 1


After a whole lotta digging, I found the answer here: https://productforums.google.com/forum/?#!topic/chrome/mxwrMGVA6FQ

When the flash player stops loading from one day to the next, it's possible that a recent DLL update to C:\Users\\AppData\Local\Google\Chrome\User Data\PepperFlash\20.0.0.xxx\pepflashplayer.dll is the cause. The xxx can vary over time: 267, 286..

To test the DLL, hide/rename it as pepflashplayerHide.dll. Close/open Chrome, which will now use it's builtin DLL. If the player works, you've found the culprit. You can stop with the Hide workaround or try to fix the problem.

To correct the problem, delete the PepperFlash folder. Close, open Chrome: the flash player should load. If the problem reappears (after the folder auto updates), there may be permissions problem (see below).

--Details-- The DLL won't load if it's 32/64 bit-type doesn't match the bit-type of Chrome. A mismatch can occur when you switch 32/64-bit Chrome versions and there was a flash player security update lately (here 12/24/15).

Type about:version in the address box to see the Chrome bit-type.

To check the type of the DLL update, look at it's size. (See the PepperFlash path above) Sizes under 17000KB are 32-bit, over 28000KB are 64-bit.

If the bit-types don't match, delete the 20.0.0.xxx folder. If the bit-types match, there can still be a permissions problem - delete the PepperFlash folder.

When you hide the DLL or delete the folder, Chrome will fall back to it's builtin version and flash should work.

After deleting the folder, you'll get an auto-update soon (usually <30 min). Or you can update it immediately from about:components.

If the problem returns with the update (watch the PepperFlash folder), try running Chrome as Administrator. If this lets the plugin load, there may be permission problems.

You can circumvent the permissions failure by hiding the DLL again, see above. This will block additional updates (to this 20.0.0.xxx) and use the less secure builtin DLL. Quick, but not optimal.

The better approach is to fix the folder permissions.. You only need to fix the 20.0.0.xxx folder, the critical permission is 'Read and Execute'. Try this succinct Best Answer (old but good) or see this recent longer one.

The 32/64-bit conflict is being worked as bug 546017. Institutional users may see the same "Couldn't load plugin" failure, but this is related to network share permissions. See bug 572131 for details.

  • I know it's not the done thing here, but I wanted to say thanks anyway. In my case, the DLL simply disappeared (perhaps due to a system restore, but it was only back a few hours so this shouldn't have even happened). Either way, reinstalling had no effect but deleting the PepperFlash folder worked in seconds! Saved me hours of wasted time. Jan 12, 2017 at 0:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .