I am trying to create a new partition on my laptop (XPS 12 9Q33, 128GB SSD) by shrinking the C:\ partition. However, despite the fact that it indicates there is enough space, it displays an error message. I have successfully done this on my desktop, but for some reason it fails on my laptop.

There is not enough space available on the disk(s) to complete this operation.

I am trying to shrink C:\ (which has ~25GB free) by 10GB.

I have:

  • ensured there are no files at the end of the sector (disabling pagefile, etc.). See How can I shrink a Windows 10 partition? for how to do that (and you do need to do that).
  • turned off my antivirus temporarily.
  • disabled BitLocker encryption.

And it still fails. I've even tried Paragon's Partition Manager, which claims there is not enough space on the disk, which is not true.

I have even tried shrinking different sizes (down to 256MB), but to no avail (it still displays the same error).


It allows me to shrink 10GB (unlike similar issues)

but fails on this message:

Any help would be appreciated.

  • I know this is a very bad thing to do on SSDs, but the problem may be that there is not enough CONTIGUOUS space on the SSD being data scattered all across the drive, so have you tried defragmenting?
    – Manchineel
    Jun 17, 2017 at 8:20

7 Answers 7


Try launching the Event Viewer to see which individual files are blocking the partition shrink.

  1. Once again, attempt to shrink the partition. You should get the "There is not enough space" error.
  2. Launch Windows' Event Viewer application.
  3. In Event Viewer, go to Windows Logs > Application.
  4. Find and Click a recent log of type Warning. It should have the message, "Error: during volume shrink initiated on volume Windows (C:) we failed to move a movable file extent." screenshot
  5. The Diagnostic details will give you the name of the "last unmovable file"
  6. Delete this file (Simply send to recycle bin. I did not need a hard delete).
  7. Try shrinking your volume again.
  8. Repeat steps 2-7 until you successfully shrink your partition. (In my case, I had to do this 3 times, as I had 3 pdf files in my local Google Drive that were for some reason stuck as 'unmovable'.).
  9. Restore your deleted files.

CAUTION: Make sure you know what you are deleting! In my case, I knew that these pdf files were:

  1. Not system files
  2. Easy to download again if they become lost
  • 3
    The event viewer was the only solution that helped me to find the remaining culprit: Google Backup And Sync seems to create files with properties that Windows 10 is unable to handle. I deleted the Google Drive folder while the sync client was shut down and the shrinking worked just fine! For the record: if the shrinking finds unmovable files, it generates a warning administrative event. Jul 4, 2018 at 15:44
  • 2
    Looking at those event viewer logs, my anti-virus (ESET) apparently has files open which block the defrag step of the shrinking.
    – user18099
    Jan 16, 2019 at 11:43
  • 1
    The event viewer helped me a lot. I had a file related to my anti-virus that wouldn't let Windows shrink the partition. It was not open or locked, it just had unusual file permissions: Deny:Read:Administrators. Instead of deleting it, I removed the "Deny" permission and Windows was able to shrink the partition. Before that I used the icacls command with the /save parameter to save the previous state and after shrinking was done, I used icacls again to restore them to the exact previous state. See icacls /? for help. Maybe @user18099 has the same issue?
    – marcus
    May 12, 2019 at 1:38
  • 1
    This answer needs more upvotes. It's the only one that teaches you how to find out what went wrong instead of just guessing.
    – marcus
    Jun 25, 2019 at 21:21
  • Coming back 4 years later and a little wiser to mark this as the correct solution (since this question seems to come up on Google a lot) - might also be worth noting that some system files are more likely to cause this problem than others (like the pagefile); this can be fixed as per other solutions here.
    – eidde
    Apr 8, 2020 at 23:52

I got this error when trying to shrink by 150GB, but shrinking three times by 50GB worked fine.

  • 5
    You are my hero, 3x10GB worked, but single 30GB didn't. Jan 4, 2017 at 11:34
  • 2
    Something similar worked for me too, strange as it seems...
    – iammax
    Nov 10, 2017 at 15:16
  • 3
    Stupid MS ;-) This even worked initially in chunks of 100GB for me, and then I had to gradually reduce the size of chunks to reach the minimum size I can get... So that I can install Linux Mint and forget about Windows as I've been doing for more than a decade now ;-)
    – Sadi
    Dec 29, 2017 at 23:54
  • 2
    Wow, I feel stupid to write "worked for me too", but this is surprising. Although I eventually had to resort to 10Gb increments for my total of 200Gb shrink. Took like 20 minutes. Jan 7, 2018 at 20:32
  • 2
    I can't stop laughing, how stupid this all is. Thanks, man. Jan 9, 2018 at 13:36

The reason why Windows won’t let you shrink the volume is as the message shown in Disk Management suggested, because there are immovable system files at the very end of the volume, as this screenshot from utility shows us. there are multiple things you could try to work this around.

  1. Run the Disk Cleanup Wizard, making sure to remove the hibernation file and all restore points.

  2. Disable System Restore

  3. Disable the pagefile ( Open up System in Control Panel, then Advanced System Settings \ Advanced \ Performance \ Advanced \ Change \ No Paging File.

  4. Disable kernel memory dump. In the same Advanced Settings, go to Startup and Recovery \ Settings and then change the Write debugging information drop-down to “None” to disable the kernel memory dump.

  5. Disable Hibernation mode in your power options \ advanced power options screen.

Reboot the machine, and then delete your c:\pagefile.sys file, following these instructions if you are having issues. details about the fix and cause of this problem, see http://www.disk-partition.com/articles/shrink-volume-not-enough-space-4348.html


MS's Disk Management never shrinked right for me, usually having this kind of problems. I'd try a different program, my best experience is with MiniTool Partition Wizard Free. It won't shrink BitLocker encrypted partitions though. Since it's your system disk, you'd better do it from some live environment (such as some Windows PE environment if you have a license for that and use MiniTool Partition Wizard Free or other Windows tool there, or GParted Live CD or SystemRescueCD if you're comfortable enough with Linux) – and DON'T FORGET TO BACKUP before shrinking the drive.

Lists of live rescue/administration environments can be found at many places, such as at gfi.com in post "Top 5 Free Rescue Discs for Your Sys Admin Toolkit".

  • Your answer was very helpful - I used MiniTool's Partition wizard from the main OS and it worked fine! However, I was under the impression that using Linux tools to resize an NTFS partition would be dangerous as the support isn't great? Anyways, thanks for your help!
    – eidde
    Apr 11, 2016 at 1:17
  • I think Linux NTFS support is getting much better recently (even though it still hogs CPU a lot). Actually recently it happened to me that shrinking NTFS drive using Partition Wizard Free from live Windows PE rendered the volume unreadable from Windows, yet from Linux I was able to rescue all data just fine. It was the only time I ever had such problem shrinking a drive though and it may have been due to faulty motherboard.
    – LuH
    Apr 11, 2016 at 22:21
  • 1
    It was bad advice: "MiniTool Partition Wizard Free" cannot resize volumes, only the paid version can do it. The free version also installs "Brave" and Norton malware. The latter can be unchecked during setup, the former just sneaks in with no question asked.
    – fviktor
    Jan 3, 2019 at 13:06
  • Tried installing the current version, it tried to sneak in Opera and McAffee, which I both unchecked and prevented. Didn't sneak in Brave. However, I couldn't find the resizing option either. I guess someone else needs to suggest other resizing software, I didn't do this kind of stuff in a long time. When I answered the question, this program was resizing in the free mode as well.
    – LuH
    Jan 6, 2019 at 14:57
  • On second attempt, I realized it offers to Move/Resize Partition on unencrypted partitions (only the boot and recovery partitions in my laptop), but won't offer it on BitLocker encrypted ones. @fviktor maybe that's your problem as well?
    – LuH
    Jan 6, 2019 at 15:13

Something that people haven't mentioned yet is the Master File Table. In NTFS that's where the disk keeps track of where all the files are. By default it is placed in the center of the partition for ease of access, but without a 3rd party program you can't move it to shrink your partition past that halfway point.


As some people mentionned, there are unmovable files on the partition. On Windows 10, fast boot and hibernate create such files, so you have to disable these features before resizing. Here are the steps to disable them (in the "pre-setup" part): https://hackernoon.com/installing-ubuntu-18-04-along-with-windows-10-dual-boot-installation-for-deep-learning-f4cd91b58557


I had this on a Windows 2016 server, the solution was to try and try again, every time choosing a smaller value till it works, and then using a larger value again till it fails. I had to repeat around 15 times to get to the desired size.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .