6

I have main router (192.168.0.1) and severals PCs connected to it, then I have another router (192.168.0.102 - this is the IP assigned to the router by the main router).

I want to use the secondary router as switch only (adn for Wi-fi) so all PCs no matter to which router they are connected could see each other in the network for file sharing.

So I have to set LAn and WAN to be in the same subnet as the main router ? It still gives me error that lan and wan cannot be in same subnet etc. When I disable DHCP I canno access the router anymore so I have to reset it.

Isn't there any guide how to configure this TP-LINK Archer C5 as "bridge" only ?

Thanks.

3 Answers 3

2

Don't use the WAN at all. If you must configure an IP, pick one that you don't care about (such as 192.168.254.1). Do not connect the WAN port to anything.

Set the LAN IP to be one inside your network but outside your router's DHCP range. So if your main router is 192.168.1.1 and your DHCP range is 192.168.1.100 to 192.168.1.200, 192.168.1.2 or 192.168.1.254 are good IP addresses for the switch.

Disable the DHCP server.

6
  • I cannot set LAN IP to be the one in the first router range because it says that the WAN and LAN IPs cannot be in the same subnet.
    – Dakado
    Apr 10, 2016 at 19:46
  • You missed the first paragraph. If you cannot disable the WAN, set it to a subnet that you aren't using. Apr 10, 2016 at 21:03
  • Once I disable DHCP server I cannot access the router anymore. This TP-LINK has terrible settings.
    – Dakado
    Apr 11, 2016 at 13:40
  • @Dakado Manually configure your machine to an IP address inside the same subnet as the router's LAN IP. Or reset it to factory settings and start over. Apr 11, 2016 at 18:36
  • Doesnt work at all, router refuses to work while disabled DHCP, I solved it with another switch right before the router. So all the devices are connected via the switch and mobile devices are connected to the wifi router.
    – Dakado
    Apr 12, 2016 at 15:54
1

I just got this working. I just bought Google WiFi in hopes of improving the WiFi networking, but I have several devices on my network that still need to be connected via Ethernet. Devices like printers didn't show up on the same network as the WiFi when I just used the Archer C5 as a downstream router. This is basically the same idea as David's answer, but with a little fleshing out.

  1. Plug the ethernet cable from your cable modem into the main router's WAN port.
  2. Connect an ethernet cable from your main router's LAN port to your TP-Link Router's LAN (not WAN!) port.
  3. Using a device connected to another of the TP-Link Router's LAN ports, go to its configured IP address in a web browser (probably 192.168.0.1).
  4. Go to Advanced -> DHCP-> DHCP Settings page. Select Disable DHCP Server, and click Save button, but do NOT reboot the router.
  5. Go to Advanced -> Network -> LAN and change the LAN IP to an IP address that is:

    1. different from the main router's IP address
    2. in the same subnet network as the root router
    3. outside of the DHCP range of the root router.

    (For example, my Google WiFi app showed the Router LAN address as 192.168.86.1, and the DHCP Address Pool starting at 192.168.86.20 and ending at 192.168.86.250. So I chose 192.168.86.2 for my Archer C5.)

  6. Save the changes and restart the router. (You should be prompted to restart.)

After the restart, everything should be peachy keen. If, like me, you just want to rely on your root router to provide WiFi, be sure to disable WiFi on your TP-Link Router. If, instead, you want to use WDS Bridging, there are some additional instructions to follow at https://www.tp-link.com/us/faq-825.html, which is where I got some of the instructions above.

Remember that if you ever need to change your router's settings again, you'll go to the new IP address that you configured instead of the original one.

0

Put a cable into main router's LAN and into the Archer C5 WAN, and configure the WAN as bridge. Disable the DHCP on Archer and put the main router's IP in the DHCP server line from the Archer's configuration page.

I made a picture of my LAN. The devices are seeing each other use Archer C5 v4's WAN as bridge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.