0

Hi everyone!
This is my first question so correct me please if I´m asking something wrong.

So my Problem is:
I´ve got a Lenovo E31-70 with pre-installed Windows 10 home 64bit and I tried to dual-boot Kali Linux on it.
First I´ve created an Partition with 100GB. Than I installed Kali Linux and the GRUB loader from an .iso image from an USB. The Installation was working fine and finally I had all installed.Then I tried to boot Windows and I got a boot error, but Linux was working well.
For some reason i cannot upload an photo of the error, but:

File: \Boot\BCD
Status: 0xc000000e
Info: The Boot Configurations Data for your PC is missing or contains errors.

After a bit searching I found that: http://answers.microsoft.com/en-us/windows/forum/all/0xc000000e-boot-error/ef08ab00-e130-4301-bc80-79d5b414a81f?auth=1
THE SECOND ANSWER

So I downloaden an Windows 10 .iso on my USB, started Windows repair, and wrote
bootrec /fixmbr bootrec /fixboot bootrec /rebuildbcd

All worked fine, Windows was completly restored, but when I restarted the PC, GRUB doesn´t appear! I´ve tried restarting the Notebook several times, with the same result.

Than I found this solution: https://forums.kali.org/showthread.php?20559-How-To-Repair-Kali-Linux-Grub-With-Kali-Linux-Live-Cd-Dual-Boot-With-Windows-7

Again all worked fine. When I rebooted the Notebook, GRUB appeared. I thought it was the end... It wasn´t.
Because when I´ve tried to start Windows, I got the same 0xc000000e Error again.

NOTE:
Fast boot is turned off
Boot Mode is legacy(can switch to UEFI)

Conclusion: When repairing Windows, GRUB doesn´t appear. When repairing GRUB, Windows boot error.

I guess that GRUB is overriding Windows boot data...

[EDIT]
I can boot windows if i switch to UEFI. The problem is: I don´t want to switch in BIOS from UEFI to Legacy every time i need to boot another OS. Is there any way to boot Windows 10 in legacy or start GRUB in UEFI?

2 Answers 2

0

Most pre-installed Windows 10 use uefi with secure boot. I'm not very sure if kali supports secure boot or not but it definitely supports uefi.

Also it seems that you are installing kali in legacy. For GRUB to appear, both os must be in either legacy or uefi.

1 : Restore you windows 10 using the steps you already mentioned.

2 : Disable secure boot from bios.

3 : Install kali in uefi (not legacy).

Now GRUB should appear.

P.S : You don't need to turn off fast boot. Also you don't need windows 10 iso specifically to repair windows. It can be done using win 7 or win 8.1 iso.

1
  • I'm not very sure if kali supports secure boot or not If you're not sure, please research and find out. Apr 18, 2016 at 12:55
0

DO NOT USED HYBRIB MBR

My Situation

  • On a 2015 MacBook Pro w OSX installed
  • I installed Windows via Bootcamp w no issues
  • In OSX I partitioned my drive to allow room for ubuntu
  • I installed Ubuntu w no issues
  • Windows no longer works, showing this error

image of windows error

Through countless hours of research I found a great link about installing windows 10 on a mac without using bootcamp

What solved my issue was the portion about "Ensuring that a Hybrid MBR is not used" and here are those steps in case the link ever dies:

Huge thanks to Rod’s post from the superuser post titled Windows detects GPT disk as MBR in EFI boot.

Once you add a FAT32 partition with either Boot Camp Assistant or Disk Utility, your disk is converted into a hybrid GPT / MBR disk which is actually not supported by newer versions of Windows. In this step, we revert this additional change made by Disk Utility by switching back to a pure GPT partition table.

Dowload the latest version of GPT fdisk by browsing to the version, then gdisk-binaries and clicking the file with the *.pkg extension (e.g. gdisk-1.0.1.pkg). Install GPT fdisk by running the installer you downloaded Open a Terminal and check the state of your MBR

1 sudo gdisk /dev/disk0 If your MBR partition is set to hybrid, please continue with step 4, otherwise if it is set to protective, you may skip the rest of this section. Simply type q and hit return to exit GPT fdisk.

Type p to view the existing partition table and verify you’re working on the correct disk

Type x to enter the expert menu

Type n to create a fresh protective MBR

Type w to save your changes and confirm the change when asked

Type q to exit GPT fdisk

Run GPT fdisk to show your disk layout:

1 sudo gdisk -l /dev/disk0

Your partition table should look something like this:

1 GPT fdisk (gdisk) version 1.0.1

2 3 Warning: Devices opened with shared lock will not have their

4 partition table automatically reloaded!

5 Partition table scan:

6 MBR: protective

7 BSD: not present

8 APM: not present

9 GPT: present

10

11 Found valid GPT with protective MBR; using GPT.

After that fix I rebooted, selected my windows partition, and violá it booted right up.

NOTE

I often hold option (alt) when booting which shows me a list of OS / USB I can boot into. I used this a lot throughout this process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .