0

I'm trying to use an in-browser Java applet but despite the webpage loading, the applet fails to load.

The applet is hosted on an internal server at another location and is accessed via a website using HTTP over port 8888. Internet Explorer connects to the server using a proxy server and successfully retrieves the applet.

I've manually set the proxy settings in the Java Control Panel and unchecked the Bypass proxy server for local addresses box as the connection needs to go through the proxy. Under the Advanced button in JCP's Network Settings I've checked the box to the use same proxy for all protocols.

By using PuTTY in RAW mode and configuring it to use the same proxy settings, I've confirmed that the website is working.

When I load the page, Sysinternals Procmon and TCPView show the jp2launcher reading the configuration file (which contains the proxy settings) but no connection is ever made to the proxy server. The jp2launcher executable attempts a direct connection to the applet server over port 8888 instead of going through the proxy server like it should.

Any ideas as to why Java is ignoring the proxy settings provided to it?

Any ideas as to how I can force Java to pass through the proxy?

Edit: IBM's Tivoli Java applet works just fine using the same settings. It's also on an internal server, passing through a proxy, and using a non-standard port (16311)

0

Sufficed to say, this problem ended up disappearing and I've no idea what caused to resolve, much less what caused it to happen.

For those of you stumbling upon this question in hopes of a resolution, I wish you the best of luck...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.