2

I am connecting to windows server 2012 through remote desktop.

The remote computer is a Terminal server where minimum of 240 users are connected.

The fonts and icons in the remote desktop window are so small, every other user who are connecting to the same server have no issue with font size or window size everything seems normal.

But when i connect to remote, the window size and font are so small. i can't use any app on remote because of font size. Please suggest..

**I tried by changing display settings and set screen size to larger on RDP Connection but no luck.

**First i have connected through a computer with normal DPI and closed my session (Logged off). I tried the next day by logging in RDP from Laptop still same issue :/ .

  • What did you set your remote desktop settings at? it could be trying to pull another resolution. Change the settings under the display tab. – NetworkKingPin Apr 11 '16 at 11:46
  • What is your machines resolution? I had issues with RDP on Surface 4 due to 4K resolution. Win Sever over RDP will not scale – Harvey Apr 11 '16 at 13:47
2

This is probably caused by the fact that the RDP protocol does DPI redirection. If you login (initially) from a machine with a normal display (e.g.: 96dpi), then you connect from a laptop that has a high DPI without logging out (e.g.: any 1080p 13" laptop that sports 120dpi), then everything will look tiny as the session will use the DPI settings that were set in the beginning.

The fix is to log in from the new computer, save and close all programs, open cmd (Win + R -> cmd) and type logoff. Wait for 1-2 minutes, then connect again. This time, all the apps and fonts should be rendered at the right resolution.

  • Can't believe the solution can be something so simple! Thanks, it fixed my problem. – Imtiaz Aug 8 '18 at 8:33
0

When you use Remote Desktop , at the bottom there is an 'options' menu .Go to experience and check everything . This may result in more connection latency , but at least you can use it !

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.