0

First, the setup: I have a Macbook running OS X 10.9.5, and I have a folder that I sync using WebDAV with a Windows machine. The way it works is:

  • My Windows machine is running the WebDAV server (IIS).
  • I mount the Windows WebDAV folder using Finder ("Go / Connect to server").
  • Once mounted on the Mac as if it was a local folder, I use Unison to sync them. (Unison is a simple program; it just syncs two folder trees, and AFAIK it doesn't care whether one of them is mounted remotely or whatever).

All of this was working perfectly fine until a few days ago, when my Mac's HD became unmountable due to a corrupted journal. I had to format and restore from a Time Machine backup. Ever since then, when I try to sync both directory trees I get these errors in my syslog:

Apr 11 20:04:15 Paulos-MacBook-Pro kernel[0]: Sandbox: webdavfs_agent(344) deny file-write-unlink /private/var/folders/25/(edited long string)/C/mds
Apr 11 20:04:15 Paulos-MacBook-Pro kernel[0]: Sandbox: webdavfs_agent(344) deny file-read-metadata /private/var/folders/25/(edited long string)/C/mds

I tried to delete that folder (only the 25 folder, not the entire /private/var/folders/ tree) and then reboot, just in case there was some stale lock file or something similar. After rebooting, I see that the 25 folder is regenerated, but when I try to sync, the same error occurs.

What's going on?

EDIT: if I log out from my current OS X session and then login again, I can sync without problems. However, if I then wait a few hours, the problem occurs again.

  • Can you edit files on the WebDAV mount even when the sync fails? i.e. does it go read-only for all programs, or is it only unison that's failing to write to it? – D Schlachter Apr 22 '16 at 16:20
  • I don't know because I haven't really tried. I only use this setup to sync files using Unison. – PaulJ Apr 22 '16 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.