0

I used to git cli interface and when I type git s and press show git autocomplete script will prompt me with options show and status

It does work in tmux. It does not work in byobu session. Byobu prompt me local files.

  • 1
    What shell are you using? (echo $0) And which operating system? Both information are missing – h0ch5tr4355 Apr 12 '16 at 7:43
  • /bin/bash OSX, but can observe it on ubuntu 14.04 – logcat Apr 12 '16 at 7:48
  • 1
    github.com/bobthecow/git-flow-completion/wiki/… OS X or Ubuntu? Not sure if this will work as you wrote that it works in tmux. byobu should recognize the completion actually by default. – h0ch5tr4355 Apr 12 '16 at 7:50
  • both installed, maybe that's terminal related? I've tried iterm2 and terminal.app – logcat Apr 12 '16 at 8:03
  • 2
    but as it is working in raw tmux, I assume something is wrong with byobu keybindings? – logcat Apr 12 '16 at 8:19
0

The problem is that I've used customized byobu prompt. So I can either disable it via byobu-disable-prompt or configure it so it will use bash completion also by adding this line . ~/.bash_profile to ~/.byobu/prompt

0

In Centos bash_completion scripts were at /etc/profile.d/bash_completion.sh

so sourcing this file inside byobu prompt solved the issue.

echo ". /etc/profile.d/bash_completion.sh >> ~/.byobu/prompt"

exit and start your byobu session again and it should work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.